WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [plugin BUG google-analytics-for-wordpress ] Error massage with Version 3.0

[Resolved] [plugin BUG google-analytics-for-wordpress ] Error massage with Version 3.0

Viewing 15 replies - 1 through 15 (of 30 total)
  • hey there, I’m having this issue too see below:

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'GA_Admin::add_config_page' was given in /home/content/07/4395607/html/wp-includes/plugin.php on line 339

    Same here. WordPress 2.8.2 upgrading this plugin to version 3.0

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'GA_Admin::add_config_page' was given in /homepages/htdocs/website/wp-includes/plugin.php on line 339

    I did get this at the end though:
    Plugin reactivated successfully.

    Count me in too!

    I found this thread when googling the error.

    Should we downgrade or wait for a fix?

    As long as stats are still being gathered, I can live without the ability to “view” them for a few days.

    And me. Just upgraded

    Same for me. Plugin looks like it’s working OK – just the error in the admin pages.

    I downgraded here and problem went away. Wait for 3.01 or something like tha.t

    How do I downgrade??

    I have NO access to my blog now

    This is NOT joyful!

    Peace,
    Alan

    I confirm bug. WordPress 2.8.2, plugin version 3.0.

    Another with the same problem. Upgraded to new plugin with 2.7.1 and getting the same messages as the others posted above. Trying to figure out how to downgrade…

    Temporary measure:

    1. Deactive Google Analytics for WordPress in your Plugin panel (if you can’t access your WordPress Admin backend, just continue with step 2 and use FTP);
    2. Delete the plugin, either through the plugin panel or by FTP (all your settings will be preserved in the database)
    3. Install Google Analytics for WordPress 2.9.5;
    4. Reactivate the plugin.

    Yoast (the plugin author) is already notified through Twitter. Expect a bugfix shortly.

    The same problem occurred here.
    Wordpress 2.8.2, plugin version 3.0.
    So, anyone expect a correction for that??

    Thank you djr, I couldn’t find the old version anywhere! (Now I know)

    the Downgrade work fine for me, but a correction for the new version is a great thing. I think.

    Thanks djr for the rollback advice. I’m now back to the previous version and I’m not getting the error messages that everyone noted.

    But yes, I’d like to add that I also received the same errors. And when I initially tried to deactivate the plugin it went to a page showing nothing but the two error messages. After hitting the back button on the browser I then noticed that the plugin was successfully deactivated after which I carried out the re-install of older version.

    Thanks again. Looking forward to the fixed updated.

    Me too.. I’ve not yet upgraded to 2.8.2. Is that the cause?

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘[Resolved] [plugin BUG google-analytics-for-wordpress ] Error massage with Version 3.0’ is closed to new replies.