Support » Plugin: BuddyPress Private Community » [Plugin: BuddyPress Private Community] BP Pvt Community does not work with 3.3

  • On enabling the plugin, when I go to any page except the homepage as a non-logged in user, I get this error:

    Warning: Cannot modify header information – headers already sent by (output started at /public_html/wp-content/plugins/buddypress/bp-themes/bp-default/blogs/index.php:12) in /public_html/wp-includes/pluggable.php on line 866

    I am using WP 3.3 with multisite functionality and the latest BuddyPress.

Viewing 11 replies - 1 through 11 (of 11 total)
  • I just got the same thing. Tried the various “fixes” but didn’t work at all. I believe this has something to do with the new version of either WP or BP.



    please have a look at


    You will find a newline at line 11. Delete this empty line
    10 ?>
    11 <?php get_header( ‘buddypress’ ); ?>

    and try again. I’m running WP3.3, BP1.5.2 and BuddyPress Private Community 0.6

    Thanks eeepee!
    That worked for me…

    Hi bojanski,

    fine… but you will have to repeat that for every Buddypress update (until this empty line will vanish). After upgrading to BP 1.5.3 and same procedure again.

    Ok, so that fixed the header problem but does this not work with other themes? I am using pagelines pro with the bp template pack and all my other buddypress components work just fine but I do not have settings for the privacy plugin and nothing is private

    Hi busysingleparent,

    this plugin has no settings page. You have to create a config-file in


    (you have to create the folder buddypress-private-community-config). Please read the documentation and FAQ how to configure the plugin. There are a number of various ways how to handle users which aren’t authenticated and what to do next.

    In the above mentioned configuration file, I use only the following statements:

    List of allowed URIs (all others are blocked, adapt this to your site):

    MM_BUDDYPRESS_PRIVATE_COMMUNITY::$ALLOWED_URIS = Array(‘/contacts’, ‘/about’, ‘/welcome’);

    redirect blocked users to starting page:


    and this for redirecting users which authenticated:


    the plugin has a sample config file which gives you some examples.

    Hi, I have a problem for buddypress. I installed buddypress and choose “Hide out of the system for users administration panel?”. After, “you do not have sufficient permissions to access this page” error. Help me please. (My English is a little. Sorry.) I’m waiting your suggestions. Thanks.

    eeepee, I am having the same trouble with getting the error
    Warning: Cannot modify header information – headers already sent by (output started at /nfs/c05/h02/mnt/74581/domains/ in /nfs/c05/h02/mnt/74581/domains/ on line 866
    I am using WordPress multisite, buddypress, Private Community plug-in.
    I deleted the 11th line that was blank like you had mentioned but I still get the error.
    My site is

    Do you have any ideas of what I could do to fix this?
    I am totally new to WordPress and PHP in general. But I do know how to use a text editor.

    This plugin seems to be working on my site, I just can’t get it to unblock the RSS feeds even when I select “FALSE” in the config file. Any help, please?

    Hi myfaith20,

    if I set


    then all feeds can be read, regardless if somebody is authendicated or not





    is set, all RSS-Feeds are blocked.

    but this switch


    doesn’t work. If the above switch is set to block, then I get no feed, otherwise reading is possible. Authentications doesn’t seem to matter. Only a quick tested with the RSS-Reader of Safari.


    Hi JustLearning,

    actually your site is running on a plan WP now. Have you looked at the exact error after deleting the empty line in:


    Perhaps you’ve got another “Warning: Cannot modify header information” on a different place. I’ve observed this empty-line problem also with some other plugins/themes.


Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: BuddyPress Private Community] BP Pvt Community does not work with 3.3’ is closed to new replies.