WordPress.org

Support

Support » Plugins and Hacks » [Plugin: BuddyPress Moderation] Not working with BP 1.6.1 WP 3.4.2

[Plugin: BuddyPress Moderation] Not working with BP 1.6.1 WP 3.4.2

Viewing 15 replies - 1 through 15 (of 21 total)
  • benjaminniess

    @benjaminniess

    Hello,

    Same problem for me

    benjaminniess

    @benjaminniess

    andrewgtibbetts you can disable the ajax feature then it will work but the page will reload each time you click. You just need to comment the wp_enqueue_script line (in classes/bpModFrontend.php line 16).

    midopicture

    @midopicture

    Hello,

    i have got the same problems like andrewgtibbetts. Now I’ve disabled the ajax feature like its’s described above. Now the flag’s getting red, but theres still nothing entered into the moderation admin. Can you please help me to solve this problem?

    Thanks

    midopicture

    @midopicture

    Hi,
    we solved the problem and we could now see the flagged posts in the backend.

    Regards

    Andrew Tibbetts

    @andrewgtibbetts

    Thanks for the fix, Ben! Hopefully an update will bring back the ajax…

    midopicture

    @midopicture

    Hi,
    i have is fix with ajax!

    WP 3.4.2
    BB 1.6.1
    Multi Networt

    Thanks for the fix. It’s working fine albeit without ajax.

    Midopicture, would you care to share your fix?

    Thanks.

    michel

    @michelklassebe

    The ajaxurl variable has been changed (http://bpdevel.wordpress.com/2012/05/01/ajax-changes-in-buddypress-1-6/)

    Here is a quick fix.
    in bpModLoader.php:
    change (line 62)

    if (is_admin()) {

    to

    if ( is_admin() && !$_REQUEST['bpmod-fe'] ) {

    add (after line 89)

    if ( $mainclass == 'bpModActions' ) {
    	add_action('wp_ajax_ajax-flag', array(&$bpMod, 'ajax_flag'));
    	add_action('wp_ajax_ajax-unflag', array(&$bpMod, 'ajax_unflag'));
    }

    in bpModFrontend.php:
    change (line 144)

    $get_data = array(
    	'bpmod-action' => $action,
    	'type' => $type,
    	'id' => $id,
    	'id2' => $id2,
    	'_wpnonce' => $nonce
    );

    to

    $get_data = array(
        'bpmod-action' => $action,
        'type' => $type,
        'id' => $id,
        'id2' => $id2,
        '_wpnonce' => $nonce,
        'action' => 'ajax-'.$action,
        'bpmod-fe' => 1
    );

    That should do the trick.

    Cheers

    Hey Michel!!

    Thanks very much for that!

    BP Moderation plugin update version buddypress 6.1 and wordpress latest.

    Thank you All sons of Buddypress! And michel for sharing.

    This plugin is Very important for our installations. Should be a core function. Sometimes I don understand why the BP developer see this. We are Users, not developers -interested in a open source flat miracle, lending wordpress core.

    Now using over 30 simple plugins just to get BP to work in a standard network way. And each upgrade breaks something.

    “Howdy” No please,

    Well, still, a huge HUG for all whos working with the Buddypress and WordPress, and giving it us for free.

    / Jonas Lundman

    Wow. Great Fix!
    Thanks Michel.

    i tried the fixes you suggested, but still dont seem to have much luck getting it to work… am running the latest bp install 1.7 though… u think that would be a reason?

    michel

    @michelklassebe

    Hey Michael,

    I tried that out but it unfortunately didn’t fix the same problem that sidjags has.

    Any other ideas? Running wp 3.5.1 bp 1.6.4 and all the moderation fixes you mentioned above… It was working before the most recent updgrade to wp & bp.

    Thanks,

    Using WordPress 3.5.1 and BP Version 1.6.4 with Clean Buddypress theme default and the fix still works. However,

    TIP

    Turn error reporting all ON and DEBUG on, I think there is a NOTICE of a unknown index in the plugin backend settings. Fix that Notice, otherwise the CUSTOM QUERY Link wont show up or work.

    It might also create other problems Im not aware of.

    BP Version 1.7, sorry, 80% of my other plugins wont work and this Great plugin might have to be rewritten.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Plugin: BuddyPress Moderation] Not working with BP 1.6.1 WP 3.4.2’ is closed to new replies.