Support » Plugin: BuddyPress Groupblog » [Plugin: BuddyPress Groupblog] Two Error Reports

  • The scenario:

    I need groups set to private or hidden with their group blogs also hidden. As members join are invited into these groups they should have authoring privileges.

    The test environment:

    WPMU 2.9.2 and WP 3.0 were tested.
    Three groups and associated blogs were created: Public, private, hidden.

    Bug Report:

    1) WPMU 2.9.2 / BP / BP Groupblog 1.4.4

    3 groups and 3 blogs created successfully.
    Admin of the group has access to all three groups and blogs.
    Member can join all three groups but only has access to the public blog.

    2) WP 3.0 / BP / BP Groupblog 1.4.4

    3 groups and 3 blogs created successfully.
    Admin of the group has access to all three groups and blogs.
    Member can join all three groups but doesn’t have access to any of the blogs as shown in the admin dashboard.

    Interestingly, the member supposedly has access to the public group blog because the option shows up in the top BuddyPress bar when logged in. When the member hovers on the “New Post” option for this blog the URL shows /publicgroup/wp-admin/post-new.php as it is supposed to. When this is clicked the member is redirected to /wp-admin/?c=1


    Please feel free to direct message me or e-mail at kylejones {at} for more information.


Viewing 13 replies - 1 through 13 (of 13 total)
  • Just adding that I too am experiencing strange User Role behavior with Groupblog:

    I created a private group and group blog (with links to the blogs front end) with default role pairings (user=author, mod=editor, admin=admin) — the blog was created successfully, and invitations were sent out.

    But my subscriber had only a subscriber role on the MAIN BLOG — When they try access they get sent to (which incidentally kills my dashboard hide script…)

    THEN, I changed the member/subscriber to moderator (by the groups admin page) and this gave them Author privileges… ON THE MAIN BLOG! No role for the group blog.

    Anyway – the plugin looks promising! I am excited to see these issues worked out. If I find a fix, I will post here.


    -Edit: deleted (double posted)-

    Here’s my digits:

    WP: 3.0.1
    Groupblog: 1.4.4

    Hey Driftless! I have just found out 5 minutes ago that I had exactly the same problem…And even that group admins become admins on the main blog!!!! ouch.

    What I noticed in the super admin, is that people do not get added as users of the different sites, but only of the main site. No clue why, but I guess that the group blog plugin should turn people into users of the blogs that are associated with the group. Right now it is not doing this…and I have no clue why…

    Looks like we are headed up the same creek… anyone have a paddle?

    I dived into the code of the plugin, trying to add different switches to change the current blog before assigning the roles… No joy. I’ll hack away again tonight and let you know what I find.

    Hello Driftless! Any chance yet in finding what is wrong with the plugin?

    Sorry – been on the road and haven’t had a chance to work on this. I’ll post here if I find anything.

    I have WP3.0.1. The Groupblog 1.4.4 does not work or add a Blog menu item to the group menu.

    I do not have WPMU, but that should not matter. Right?

    Any suggestions?

    I was able to activate the Groupblog. I tried to create one in a new group, with the following parameters:

    Or, create a new blog
    Enable member blog posting (both checked and unchecked)
    Default Roles

    This is what I got:

    Fatal error: Call to undefined function wpmu_validate_blog_signup() in /home1/toxinfr1/public_html/nestever/wp-content/plugins/bp-groupblog/bp-groupblog.php on line 524

    So it appears the plugin is looking for wpmu. But I am running WP3.0.1., and the latest update of BuddyPress.

    How can I correct this bug?
    Or does the fix have to come from the developers?
    Could there be a conflict with one or more plugins?

    I do not have WPMU, but that should not matter. Right?

    Hi Kevinschmidt – I’m pretty sure that DOES matter, since groupblog promises to create new blogs for each group. In order to do that, you must have WPMU (or rather, in 3.01 – Multi-site enabled).

    Your error

    Call to undefined function wpmu_validate_blog_signup()

    refers to a WPMU function, which is no found under ms-functions.php — which is a long way of saying, you need to enable Multi-site.

    Good luck. Though please read the above comments before plunging into groupblog.

    Plugin Author Mariusooms


    Fixed as per version 1.4.6. Please update and report if you find more issues. Thanks.

    Hi Mariusooms, noticed a week ago our 1.4.4 version had the problem described above.

    Upgraded to wp3.0.1 & gb1.4.9, still didn’t work
    Upgraded bp to still not working
    Tried rolling back to groupblog plugin 1.4.6 where changelog indicated it was fixed, no luck
    Currently am setup with wp3.0.1 – bp – groupblog 1.4.9.

    I’ve tested this with all levels of users, various privacy settings and newly created groups vs existing groups. Have tried disabling then enabling plugins as well as turning off then back on the groupblog feature for a group. Have all other plugins disabled including mu-plugins, only things active are wp bp and groupblog. Sites are in subfolders, not using subdomains.

    Can you pretty please give me assistance to fix? Before 1.4.4 all was well.

    In troubleshooting I installed a fresh out of the box wp3.0.1, bp and gb1.4.9 and it works as it’s supposed to, users are added to groupblog. I put my theme in there and it still works as it should. Somewhere in the upgrade process is a hitch. I’m not a php guru so not sure what to try other than all variations of upgrades possible from where I started, have seen some info about xml-rpc problems, have also heard of some problems going straight from wpmu to wp3.0.1, anyone have any input or suggestions?

    Plugin Author Mariusooms


    It is a tough one AnnieFrancis. It looks you are doing everything right, I don’t really have a fix for you. Hope you will figure it out.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: BuddyPress Groupblog] Two Error Reports’ is closed to new replies.