BuddyPress Groupblog
Catchable fatal error (10 posts)

  1. gtstigall
    Posted 5 years ago #

    So I think I am having some issues with Group Blog.

    I have been testing Groupblog (version 1.4.4) with WordPress 3.0 (Multisite enabled) and Buddypress When it is enabled, I get the catchable fatal error at the bottom. It also is loading up all posts made by the group admin instead of creating a distinctly new blog.

    Anyone know what might be going on? Thanks!


  2. Anthony
    Posted 5 years ago #

    For me the plguin is working great except for this error:

    Catchable fatal error: Object of class WP_Error could not be converted to string in /var/www/wp-includes/ms-blogs.php on line 60

  3. gtstigall
    Posted 5 years ago #

    That is the exact error I am getting. Also, the 'group blogs' is basically importing the individual blogs of each member.

    The catchable fatal error seems pretty widespread with little support, which is frustrating because this would be an AWESOME feature for my website.

  4. slaats
    Posted 5 years ago #

    I'm getting a similar error -
    Catchable fatal error: Object of class WP_Error could not be converted to string in /web/sites/wordpressmu292/wp-includes/wp-db.php on line 488
    Has there been any resolution?

    Running WPMU 2.9.2 and Buddypress

  5. anindyaray
    Posted 5 years ago #

    I am having the same problem , with exactly the same error msg.
    In the individual group page its showing the blog tab but when clicked , its showing that its a broken link ...........

    in admin menu , under site I seems that the group blog doesn't create any blog at all , I mean no site is showin while creating with group blog .......

    but on the other hand its wordking fine on the localhost, when I an checking it in localhost .........

    I'm using WP 3.0.1 , BP , BP-group blog 1.4.4

  6. Mariusooms
    Plugin Author

    Posted 5 years ago #

    I have not been able to duplicate or trace this back as of yet. Please give a detailed description when in the creation process you receive this error. Also mention if you a subdomain install or subdirectories. Finally the version of WP and BP.

    Also try another approach and see if you are successful by creating a group WITHOUT a blog. Then, AFTER the group has finished all steps, visit the admin section of the group and enable the groupblog. I remember this approach might work for subdomains, but I can not verify.

  7. anindyaray
    Posted 5 years ago #

    Dear Mariusooms,
    I am sorry let you know that I have also tested it the way i specify as suggestion ....... and I am using WP 3.0.1 , BP , BP Group Blog 1.4.4 ........

  8. ambitionLab
    Posted 5 years ago #

    Mariusooms, I'm having the exact same issue as gtstigall & Anthony. Same versions of everything as gtstigall, same error as the one Anthony posted.

    I'm using subdomains, and indeed I only get the error when trying to create the group blog during group creation.

    There's a clue in the database... In the table wp_bp_groups_groupmeta the groupblog_blog_id value isn't numeric for groups that exhibit this particular issue. Here's an example value:

    O:8:"WP_Error":2:{s:6:"errors";a:1:{s:10:"blog_taken";a:1:{i:0;s:20:"Site already exists.";}}s:10:"error_data";a:0:{}}

  9. Mariusooms
    Plugin Author

    Posted 5 years ago #

    I am so sorry, but for now we can not get subdomains to work. I'm not sure why and haven't been able to crack the problem. It would be great to get another set of eyes on there.

    For now we only support subdirectories, but we are hoping we will be able to conquer this and support subdomains as well.

    I'll include it in the readme that subdomains are unsupported for now.

  10. hkcharlie
    Posted 5 years ago #

    Has anything moved forward with this?

    I have just experienced the error.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • BuddyPress Groupblog
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic