Support » Plugin: BuddyPress Group Email Subscription » [Plugin: BuddyPress Group Email Subscription] Unwanted HTML in email Subject Lines

  • Resolved BlueDot

    (@bluedot)


    Thanks for the plugin!

    Our users are receiving link tags in the subject lines of their emails. How do we change this?

    This is a typical subject line:
    FW: <a href="http://www.quantumactivist.com/members/tantrawave/" title="David Rowe-Caplan">David Rowe-Caplan</a> posted a new activity comment in the group The Quantum Book of the Dead [Quantum Activist]

    Thanks

    ri

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Dwenaus

    (@dwenaus)

    the function is called subject_clean or something like that. It might not be working because you have a title attribute in there. not sure. are you using the latest version of the plugin, is there another plugin that is inserting that title?

    Plugin Author Dwenaus

    (@dwenaus)

    interesting site 🙂

    We’re using Version 2.8.2.

    Is it this portion?

    `function ass_clean_subject_html( $subject ) {
    $subject = preg_replace( ‘/:$/’, ”, $subject ); // remove trailing colon
    return apply_filters( ‘ass_clean_subject_html’, $subject );
    }’

    Trying to debug is difficult as I would have to create new posts for each plugin that I turn back on, and it will send mails to everyone and their mothers.

    Do you have a recommendation to add some cleaning within this plugin that doesn’t rely on a variable that can be changed by other plugins?

    Thanks

    ri

    Plugin Author Dwenaus

    (@dwenaus)

    there is a way in the back end to preview the digested emails and not send them. just add ?sum=1 to any url. that will help you debug. As to why your install does this I have no idea. I believe some plugin is inserting the title tag. or maybe it’s a 1.28 thing. if it’s really important I could spend an hour or two and track down the exact cause, but i’d have to charge for that.

    Thanks for your help!

    Yes, please let us speak via email to discuss your access and billing arrangements.

    ri@bluedotproductions.com

    ri

    I have the same problem – it started yesterday only after upgrading to the the latest BP 1.2.8 and WP 3.1

    It is upsetting the members a little – they don’t like seeing code in their subject box!

    It seems to be unique to massages with the string ‘posted a new activity comment in’ and is not a problem with any other messages.

    Greetings Dwenaus

    Looks like we should probably fix this for everyone! I’m willing to invest.

    Thanks

    ri

    Yes just in case you haven’t noticed a few points:
    Before the upgrade there was no hyperlink to the profile of the person posting – after the upgrade there is and it is this link that breaks up into raw code in the email subject and in the first lines of the email.
    If you paste the subject into Dreamweaver it renders as a perfectly normal working hyperlink (weird!)
    I think it only happens when a person has clicked the Reply button on a previous post

    I think there must be some escape characters before the html brackets to make the subject render this way. I’m going to just try to disable the link to the posters profile until it is fixed. I’ll let you know if I manage to do that – hope you do the same.

    Plugin Author Dwenaus

    (@dwenaus)

    Ri, thanks for supporting this plugin. The new version 2.8.3 is out and fixes this problem. Actually the problem had nothing to do with wp 3.1 and bp 1.2.8. it had to do with the latest feature i added to this plugin which was to enable activity commenting. after some digging i realized i had been setting the subject wrong, not cleaning the html like i did the others. problem solved. complexity breeds more complexity.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: BuddyPress Group Email Subscription] Unwanted HTML in email Subject Lines’ is closed to new replies.