WordPress.org

Support

Support » Plugins and Hacks » [Plugin: BuddyPress Group Email Subscription] Emails not parsing quotes and apostrophes

[Plugin: BuddyPress Group Email Subscription] Emails not parsing quotes and apostrophes

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Boone Gorges

    @boonebgorges

    That looks good to me. Maybe it got double encoded here on the forums? Can you post the problematic email again, this time between backticks, so that it is unformatted?

    Oh yes you’re right, I didn’t check my post after I made it. Here is a screenshot:

    View post on imgur.com

    I too am noticing this behaviour, specifically with apostrophes – I haven’t tested other special characters.

    I am using latest versions (WordPress 3.4, Buddypress 1.5.6 and BuddyPress Group Email Subscription 3.1.2)

    I have now fixed this, thanks to a post from sboisvert. Adding the following line to bp-activity-subscription-digest.php did the job:

    add_filter(‘digest_item_content’,’stripslashes’);

    I still have this problem; anybody else?

    Actually, I think the problem just lies in the admin notices that are sent. The regular digests are stripping out the slashes. Is there a way to apply this filter to the admin emails? Maybe add something in bp-activity-subscription-functions.php in the function ass_admin_notice() section starting at line 1401?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: BuddyPress Group Email Subscription] Emails not parsing quotes and apostrophes’ is closed to new replies.