WordPress.org

Support

Support » Plugins and Hacks » BuddyPress Courseware » [Resolved] [Plugin: BuddyPress Courseware] Warning: array_merge() [function.array-merge]: Argument #2

[Resolved] [Plugin: BuddyPress Courseware] Warning: array_merge() [function.array-merge]: Argument #2

  • Fresh installs, no extras…

    BuddyPress – Version 1.6.
    BuddyPress Courseware – Version 0.9.7

    Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /home/dougm196/public_html/nes/wp-content/plugins/buddypress-courseware/roles/roles.class.php on line 269
    
    Warning: Invalid argument supplied for foreach() in /home/dougm196/public_html/nes/wp-content/plugins/buddypress-courseware/roles/roles.class.php on line 271

    It shows up when I click on the courseware tab. The tab to setup courses. If I click courseware under the admin section this is ok, I can change the settings.

    http://wordpress.org/extend/plugins/buddypress-courseware/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Stas Su?cov

    @sushkov

    It’s a warning, you can ignore it.

    It’s kind of hard to ignore being right in the middle of everything.

    Don’t take this wrong but this shouldn’t be here for the rest of the time I’m running this site should it? Not making too much sense to me.

    I should say it’s kind of a moot point at this point in time because I’m putting something a little different together but still doesn’t make too much sense, for me anyways.

    put the (array) part in
    $group_members = array_merge( $group_admins, (array)$group_members['members'] );

    it worked for me.

    jimxxx,
    Where does one PUT IN this magic? Pretend some of us may not be coders. ;o]

    Add it to what file?
    Add it to what line in that file, if important?
    Where is that file located?

    Thanks in advance.

    @dr3amscap3,
    You want to make the suggested changes to the following file:
    /wp-content/plugins/buddypress-courseware/roles/roles.class.php

    Save it to your computer, open it up in an editor such as Notepad++, do a text search to find the right place, follow jimxxx suggestion as far as backup is concerned, make the changes, save it and upload it. Worked for me also.

    Cheers.

    I had the same problem and this fixed it, thank you everyone!

    Forget it. I moved to WP Courseware and I haven’t looked back. http://flyplugins.com/wp-courseware-premium-wordpress-plugin/

    (Thank you for the assistance on this. Just ran into too many bugs.)

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] [Plugin: BuddyPress Courseware] Warning: array_merge() [function.array-merge]: Argument #2’ is closed to new replies.
Skip to toolbar