WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Buddypress-Ajax-Chat] Parse error on line 785

[Plugin: Buddypress-Ajax-Chat] Parse error on line 785

  • I’ve tried installing this plugin every which way, and keep getting the same error.

    Plugin could not be activated because it triggered a fatal error.
    Parse error: parse error in C:\Users\Becky\wamp\www\wordpress\wp-content\plugins\buddypress-ajax-chat\bp-chat.php on line 785

    Since 785 is just a ?>

    And 781 is just a }

    I’m not entirely sure what’s going on.

    Only other plugin installed is BuddyPress v1.2.2.1. Running WAMP 2.0 with PHP v5.2.9.

    http://wordpress.org/extend/plugins/buddypress-ajax-chat/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi,

    Did you modify the plugin? Looks like there is a php error in it, but in my testing on wordpress single and wordpress mu I didn’t see that and I just reran a test from scratch where the plugin didn’t exist, then I installed via wordpress (on single) and activated the plugin. No issues.

    Check the php error log or enable php errors on the display to see what might be happening in your case to find out.

    Please let me know how you make out. Perhaps it is a strict php tags config difference in your php.ini? Anyway, please let me know.

    Thanks,
    Dave

    i just installed. I’m getting the following error in a
    window chat:

    Parse error: syntax error, unexpected ‘}’ in /home/platohel/public_html/gransar.net/learning/wp-content/plugins/buddypress-ajax-chat/bp-chat/chat/lib/class/CustomAJAXChat.php on line 333

    Please confirm that the plugin created a bp-chat/config/bp-chat-config.php file and a style file as well. Otherwise you need to chmod 777 the config direction and then press the Dashboard link as admin to allow those files to be created.

    you need to go to line 696 and change

    <?

    to

    <?php

    This plugin should probably be updated to use full php open tags.

    Hi,

    1.2.8 does this now. Please grab it.

    Thanks,
    Dave

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Buddypress-Ajax-Chat] Parse error on line 785’ is closed to new replies.
Skip to toolbar