Support » Plugin: Buddypress-Ajax-Chat » [Plugin: Buddypress-Ajax-Chat] Does not work with WP 3.0.3 and BP 1.2.6

  • This is the error hint afte activating your plugin:

    Query: SELECT userID, userName, userRole, channel, UNIX_TIMESTAMP(dateTime) AS timeStamp, ip FROM wordpress_unitedcasting.ajax_chat_online ORDER BY userName; Error-Report: Error-Code:

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author dfa3272008

    (@dfa3272008)

    Make sure you chmod 777 bp-chat/config.

    hi @dfa3272008
    i came with the same problem and i am sure that i have “Make sure you chmod 777 bp-chat/config. “,but it still not work.

    thanks

    Plugin Author dfa3272008

    (@dfa3272008)

    This error means that there was an error in the database. It could be a funny character in the database itself perhaps. Please check bp-chat/config directory and make sure the correct database settings are in there and they are correct in the config file.

    Specifically the database’s host, user and password. If these are wrong then you’d get that error message I think.

    hi @dfa3272008,

    thanks for your timely reply.i check the bp-chat-config.php file again.
    the connection information is correct.

    because the source code and database are in the same server,i used localhost as database host name.
    when i login to chat,there is no data in table ajax_chat_online
    (supposed to have data when user login)

    when i changed to IP,
    it works well!

    i don’t know what’s wrong with localhost.
    (i can login mysql use localhost though in command)

    thanks
    Rocky

    Plugin Author dfa3272008

    (@dfa3272008)

    Cool, that’s an easy one:) Sounds like you don’t have localhost defined in your /etc/hosts file. Please make sure it is. Many things can break if you don’t do that.

    Enjoy,
    Dave

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Buddypress-Ajax-Chat] Does not work with WP 3.0.3 and BP 1.2.6’ is closed to new replies.