BuddyPress Activity Plus
Plugin not Working for Links and Video (16 posts)

  1. sweetmelody
    Posted 4 years ago #

    Except photos uploading, links and videos embedding can't be previewed and posted. Please help, really love the awesome plugin.


  2. DavidM
    Posted 4 years ago #

    Hi sweetmelody,

    I haven't encountered that issue before myself. Have you checked for javascript or css errors on the page?

    If you're not quite sure how to do that, the best route may be to deactivate other plugins to see where there may be a conflict.

    Also, would you happen to be using the BuddyPress default theme? If not, could you quickly switch to that to see if it resolves the issue?

  3. sweetmelody
    Posted 4 years ago #

    Hi David,

    How do I check javascript or css errors?

    I'm using Genesis Connect http://www.studiopress.com/plugins/genesis-connect - A bridge between Genesis framework and Buddypress. Is it because of this reason that I couldn't use the plugin?

    Hope it can be solved, the extension is marvelous! Thank you!

  4. masonjames
    Volunteer Moderator
    Posted 4 years ago #

    Hiya sweetmelody,

    Can we get a link to your site? We can check for js/css errors.

    We haven't tested with genesis-connect, but I don't think it would cause any issues here.

    You can check for these yourself by using a firefox extension called firebug. Just do a quick google search for it - there's also a version for chrome.

    Once installed, enable the 'scripts' tab and then refresh any page. From the console tab you'll be able to see any errors happening on your site. It's a pretty fantastic tool!

    Hope this helps. Thanks!

  5. sweetmelody
    Posted 4 years ago #

    Thanks for the info about javascript check, however, I can't understand the meaning of the error messages. Poor me. :(

    Here's my link.

    Thank you!

  6. Jean-Marc
    Posted 4 years ago #

    Hi guys,
    Awesome plugin.
    The simple_html_dom funtions clash with other plugins such as transposh for example.
    How can we make these functions unique so they do not clash. It seems like many plugins use the same html dom functions. Is there a way to address this in your plugin?

  7. Jean-Marc
    Posted 4 years ago #

    Hi guys,
    Another question. How do I add an ajax loader to the interface where a loader gif can show when users click to insert a photo, link or video?

    Thanks for your time.

  8. maindreas
    Posted 4 years ago #

    Just to say I had similar probs.

    Images and links wouldn't load ( and not just for this plugin). I took masonjames advice on the WPMUDEV forum and downloaded the firebug add-on to firefox.

    It told me the prob was with a plugin I had deleted - WP Super Cache. So I reloaded the super cache plugin which repaired itself.

    Now everything is working super. Can't praise the plugin and masonjames advice enough about using fiirebug. Have being trying to sort out the upload of images on plugins for ages. Thanks again

  9. DoctorDR
    Posted 4 years ago #

    @masonjames, I've just discovered the same issue - http://skiddnet.com/activity/ - the problem only lies with the preview function since it's still possible to enter a link in the status update and for the oEmbed function to determine if it's a video or standard link.

    I will take a closer look via firebug, but in the meantime would welcome anyone's thoughts or suggestions from past solutions.

    I am running up-to-date versions of WP (3.21) and BP (1.29) with a custom theme built from bpdefault.


  10. DoctorDR
    Posted 4 years ago #

    By a process of elimination I've managed to track down the source of the conflict - the new 'Social' plugin from mailchimp - http://mailchimp.com/social-plugin-for-wordpress/

    Any suggestions for how I might go about resolving the conflict? (since I'd very much like to continue using BOTH plugins)

  11. THX 1138
    Posted 4 years ago #

    Yeah, for me it was Transposh...too bad really, really could use that plugin, it's a balance between features for users and features for non-english speakers...it's a tough call

  12. masonjames
    Volunteer Moderator
    Posted 4 years ago #

    Hiya folks,

    Thanks for your feedback and praise :) We've released an updated version that works with BuddyPress Group Documents as well:

    As to the specific plugin conflicts, we'll do the best we can, but if the conflict is due to a separate plugin with buggy code there's little we can do other than report to the developers.

    Thanks again everyone!

  13. scott@floridabass.net
    Posted 4 years ago #

    I just get a "Failed" after i try to do anything.

  14. miguelcortereal
    Posted 3 years ago #

    I just got the same issue on my site. It only broke the function to embbed a link we can see the waiting icon but nothing more, images and videos are working fine.

    So I deactivated other installed plugins and then a yes to a plugin conflict.

    The Plugin in question is Lightbox Plus. Why do I need Lightbox? Because there's another plugin that allow users upload on the fly files to bbpress forums, when images are uploaded, Lightbox can make slide shows from them which is great.

    Any help on how to prevent the conflict between activity plus and lightbox Plus?

    I've tried to change some settings either on Lightbox and uploader plugin by changing Rel to Class, both allow that but without success the issue is still there.

    My setup is running with WP 3.3, Buddypress 1.5.2 with default theme, Activity plus 1.3.1

  15. miguelcortereal
    Posted 3 years ago #


    Don't bother with me, I just solved my issue.

    Lightbox Plus is gone, instead I have Jquery colorbox, does the same and no incompatibility with Activity Plus. Everything working fine now.

  16. avemejia
    Posted 3 years ago #

    Hi everyone,
    Perhaps you can help? I am helping maintain an education portal. We experience the same problem with our website, that is, encounter errors whenever we post a video (e.g. Youtube link) and URL.

    The message simply says "There has been an error processing your request".

    I checked the Worpress version (3.3.2) and Buddypress (version 1.5.5) and they are compatible with the plugin. We have 30 plugins activated, I wonder if one of these has a conflict and causes the error?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • BuddyPress Activity Plus
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic