Support » Plugin: BuddyPress Activity Plus » [Plugin: BuddyPress Activity Plus] Impossible to upload a picture and add link not working

  • Resolved berberetata


    I can’t upload picture on my activity and I can’t add link. Only video is working.

    For the picture I always get a “Failed” message and when I try to reach the picture I have a URL like

    The add link is loading but nothing ever happened.

    I have desactivate all my plugins and it still don’t work, I have test with the default them as well and it don’t work.

    I don’t know what it’s the problem.

    My error log file is not showing any error also.

    I’m very lost right now.

    Am I the only one with this problem ??

    Everything else is working fine.

    My website is

    Awaiting for any reply,


Viewing 15 replies - 1 through 15 (of 29 total)
  • Hi there!

    Have you checked your permissions on your upload folder?

    They may be restricting you.

    Also are you having the same problem with different browsers?




    My my upload foled is set to permission 755 so I guess it’s good.

    I have the same problem in IE and Firefox !


    Very strange.

    Can you upload Media to your Media library?

    or is this only with the Buddypress Activity Plus plugin?

    Yes I can upload Media to my Media Library.

    It’s only not working with the Buddypress Activity Plus plugin

    its true.
    image upload is not working with Buddypress Activity plus.
    the usual image uploads work fine.

    Perhaps you can give me some details of your install, I’ve just tested this in a Sandbox site and am having no problem with it.

    Which version and which version of WP are you using?

    Have you tried with the default BP Theme?

    hi klipari
    >> I am using WP 3.4 and buddypress 1.5.6
    >> I have a multisite subdomain install, on a Linux server.
    >> I am using theme “Frisco”. but i have also tried using default buddypress theme.
    >> My blogs.dir & uploads folder permission is set to 755 & 777 (cheked bothways)
    >> I have tested on Chrome & Firefox, and with varieties of image types n sizes.
    >> I have also tried after deactivating all other plugins.

    In every case image upload either gets stuck when its almost done.
    it just says image upload failed.
    Although every other function (Add image URL, Add video URL, Add link URL) works fine.
    I have also attached a screenshot for reference here.

    Please go ahead & see for yourself, the url is
    You can use this login, it will be quick
    username- test21
    password- 12345
    What version are you using, i will try the same and let you know.
    thanks 🙂


    Can you please check if the subdirectory named “bpfb” exists in your uploads directory?

    Yes i have the subdirectory bpfb allready


    Any solution to this?

    I was going crazy trying to sort this out. Eventually I tracked it down to security changes that had been made by my hosts with their implementation of Mod Security on Apache, which meant some Ajax calls to /admin/admin-ajax.php were getting blocked on the server.

    A few tweaks later and everything was OK. That’s not necessarily the problem here, but if you’re having issues I’d check with your hosts to see if they’ve done the same.

    There’s a good article on the general problem here:

    I’m having the same general problem. If I upload an image, most of the time, it returns “failed”. Sometimes, it hangs at about 21% in the upload (it might go to “failed” if I wait long enough). I’m using Suffusion (theme) but also have tried with the BP Default theme.

    My server permissions are set to allow large file uploads, and but I’m uploading small (and very small) files, to test things out. My folder permissions for the upload directories are at 775.

    I just attempted up upload a file, had it fail, and then checked my Mod Security log, and there were no entries from today, so it doesn’t seem that it’s being invoked… so I don’t think that’s the problem, but I don’t know much about Mod Security.

    My error log for the cPanel account doesn’t show any problems, either.

    I’m running the most recent versions of BuddyPress and WordPress on a VPS with plenty of resources.

    Any further suggestions would be appreciated.

    – Matthew

    (Currently, I’ve disabled the plugin to avoid frustrating my site visitors.)

    same problem here, BP 1.6.4, WP.3.5.1 = was working for months and all of sudden wammo – stopped working with failed msg as above, checked permissions, 777, files that “fail” are being written, i checked, yet plugin retutns failed upload and broken thumb


    Just to add to the confusion:

    On WP 3.5.1 – my picture upload and video uploads works just fine, but links ending on numbers does not seem to work

    Try this one

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘[Plugin: BuddyPress Activity Plus] Impossible to upload a picture and add link not working’ is closed to new replies.