BuddyPress Activity Plus
[resolved] Impossible to upload a picture and add link not working (30 posts)

  1. berberetata
    Posted 4 years ago #

    I can't upload picture on my activity and I can't add link. Only video is working.

    For the picture I always get a "Failed" message and when I try to reach the picture I have a URL like mydomain.com/wp-content/uploads/bpfb/tmp/undefined

    The add link is loading but nothing ever happened.

    I have desactivate all my plugins and it still don't work, I have test with the default them as well and it don't work.

    I don't know what it's the problem.

    My error log file is not showing any error also.

    I'm very lost right now.

    Am I the only one with this problem ??

    Everything else is working fine.

    My website is youhavefailed.com

    Awaiting for any reply,



  2. klipari
    Posted 4 years ago #

    Hi there!

    Have you checked your permissions on your upload folder?

    They may be restricting you.

    Also are you having the same problem with different browsers?



  3. berberetata
    Posted 4 years ago #


    My my upload foled is set to permission 755 so I guess it's good.

    I have the same problem in IE and Firefox !


  4. klipari
    Posted 4 years ago #

    Very strange.

    Can you upload Media to your Media library?

    or is this only with the Buddypress Activity Plus plugin?

  5. berberetata
    Posted 4 years ago #

    Yes I can upload Media to my Media Library.

    It's only not working with the Buddypress Activity Plus plugin

  6. roxor
    Posted 4 years ago #

    its true.
    image upload is not working with Buddypress Activity plus.
    the usual image uploads work fine.

  7. klipari
    Posted 4 years ago #

    Perhaps you can give me some details of your install, I've just tested this in a Sandbox site and am having no problem with it.

    Which version and which version of WP are you using?

    Have you tried with the default BP Theme?

  8. roxor
    Posted 4 years ago #

    hi klipari
    >> I am using WP 3.4 and buddypress 1.5.6
    >> I have a multisite subdomain install, on a Linux server.
    >> I am using theme "Frisco". but i have also tried using default buddypress theme.
    >> My blogs.dir & uploads folder permission is set to 755 & 777 (cheked bothways)
    >> I have tested on Chrome & Firefox, and with varieties of image types n sizes.
    >> I have also tried after deactivating all other plugins.

    In every case image upload either gets stuck when its almost done.
    it just says image upload failed.
    Although every other function (Add image URL, Add video URL, Add link URL) works fine.
    I have also attached a screenshot for reference here.

    Please go ahead & see for yourself, the url is pidia.org/activity
    You can use this login, it will be quick
    username- test21
    password- 12345
    What version are you using, i will try the same and let you know.
    thanks :)

  9. vebailovity
    Posted 4 years ago #


    Can you please check if the subdirectory named "bpfb" exists in your uploads directory?

  10. berberetata
    Posted 4 years ago #

    Yes i have the subdirectory bpfb allready

  11. roxor
    Posted 4 years ago #


  12. mbloom
    Posted 4 years ago #

    Any solution to this?

  13. louverture
    Posted 3 years ago #

    I was going crazy trying to sort this out. Eventually I tracked it down to security changes that had been made by my hosts with their implementation of Mod Security on Apache, which meant some Ajax calls to /admin/admin-ajax.php were getting blocked on the server.

    A few tweaks later and everything was OK. That's not necessarily the problem here, but if you're having issues I'd check with your hosts to see if they've done the same.

    There's a good article on the general problem here: http://www.binarymoon.co.uk/2011/05/wordpress-mod-security-2/

  14. jmatthewgore
    Posted 3 years ago #

    I'm having the same general problem. If I upload an image, most of the time, it returns "failed". Sometimes, it hangs at about 21% in the upload (it might go to "failed" if I wait long enough). I'm using Suffusion (theme) but also have tried with the BP Default theme.

    My server permissions are set to allow large file uploads, and but I'm uploading small (and very small) files, to test things out. My folder permissions for the upload directories are at 775.

    I just attempted up upload a file, had it fail, and then checked my Mod Security log, and there were no entries from today, so it doesn't seem that it's being invoked... so I don't think that's the problem, but I don't know much about Mod Security.

    My error log for the cPanel account doesn't show any problems, either.

    I'm running the most recent versions of BuddyPress and WordPress on a VPS with plenty of resources.

    Any further suggestions would be appreciated.

    - Matthew

    (Currently, I've disabled the plugin to avoid frustrating my site visitors.)

  15. maddogmcewan
    Posted 3 years ago #

    same problem here, BP 1.6.4, WP.3.5.1 = was working for months and all of sudden wammo - stopped working with failed msg as above, checked permissions, 777, files that "fail" are being written, i checked, yet plugin retutns failed upload and broken thumb


  16. acebone
    Posted 3 years ago #

    Just to add to the confusion:

    On WP 3.5.1 - my picture upload and video uploads works just fine, but links ending on numbers does not seem to work

    Try this one


  17. Aliceembroid
    Posted 3 years ago #

    the pictures work for me, I am not sure about video but the do not have thumbnail. This was the main thing I wanted the plugin for. Has anyone figured it out?

  18. dhaine
    Posted 3 years ago #

    I'm having same problem, any idea what I can do to solve this ?


    Always ends up "Failed"

  19. ellbristow
    WPMU DEV Support Staff
    Posted 3 years ago #

    Did anyone look into the suggestions made by @louverture?

    This certainly sounds like a permission/security issue. I can't replicate it on my own test server.

    Has anyone here tested it with BP 1.7 to see if it fixes it for those who had issues?

  20. JoeNative
    Posted 3 years ago #

    Hi, BP 1.7 images load. But the add this button seems to be missing?

  21. ellbristow
    WPMU DEV Support Staff
    Posted 3 years ago #

    Do you have a link to a page I can take a look at?

  22. JoeNative
    Posted 3 years ago #

    Unfortunately Not. I have stopped using it.

    Burt to clarify, if you enter text, a button appears on bottom right hand corner that says add to post/post this

    If you load a picture/video or link no button appears on bottom right corner to add to the stream.

    The links/pictures load but you can't add them to the stream. Hope this helps?

  23. bafakos
    Posted 3 years ago #

    I have the same problem. Any help would be appreciated!

  24. JoeNative
    Posted 3 years ago #

    Yup, any feedback on an update for this plugin yet?

  25. ellbristow
    WPMU DEV Support Staff
    Posted 3 years ago #

    This is working fine on my test server.

    To add pictures you first upload the image then you click the "Add Pictures" button underneath the image. This posts the image and any text you have entered.

    For videos and links, you enter the URL then click Preview, then you can click "Add Link" or "Add Video".

    Is this not working for you?

  26. tkhan
    Posted 3 years ago #

    I have just discovered this plugin and it would be ideal for what I want to do
    I am having issues like above

    I am using buddypress 1.7.1 and wordpress 3.5.1 and am using the default buddypress theme

    bpfb directory exists with file permissions 755

    Post update works for just text works as usual

    Post update and attach media button work together

    The upload file button works and the image is uploaded and shows preview
    the add image url button works and shows preview

    The add photos button causes the preview thumbnail and the update text to disappear if you click post update however the initial text is still posted but no photos appear.

  27. tkhan
    Posted 3 years ago #

    Hi got it working, I deactivated all my plugins and reactivated them one by one. I had Buddypress Media installed which was adding the attach media button I mentioned above after the upload image and add image url buttons and was obviously interfering with functionality of BuddyPress Activity Plus.

    I think it is worth mentioning that if I add an image the page needs refreshed for the update to appear making it appear as if nothing has happened.

  28. Aristeides Stathopoulos
    Posted 3 years ago #

    @berberetata has this issue been resolved with the last update?
    Do you still require assistance on this issue?

    Please advise.

  29. Aristeides Stathopoulos
    Posted 3 years ago #

    So what you're saying is that there's a conflict with the bp-polls plugin?

  30. ellbristow
    WPMU DEV Support Staff
    Posted 3 years ago #

    I'm sorry, I'm not sure I really understand your last post. If you suspect their could be a conflict with another plugin, can you try disabling this plugin and see if that fixes your problem?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • BuddyPress Activity Plus
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic