Support » Plugin: Browser Rejector » [Plugin: Browser Rejector] X-UA-Compatible invalid HTML

  • Resolved yellyc

    (@yellyc)


    I’ve just been doing some HTML validity tests on my site and I picked up that the X-UA-Compatible tag that the plugin prints on each page is invalid. To fix that, I’ve wrapped it in a conditional comment, as it is only needed on IE. any chance of this making it in?
    The change:
    on line 391 of browser-rejector.php
    echo '<meta http-equiv="X-UA-Compatible" content="chrome=1" />';
    becomes
    echo '<!--[if IE]><meta http-equiv="X-UA-Compatible" content="chrome=1" /><![endif]-->';

    http://wordpress.org/extend/plugins/browser-rejector/

Viewing 1 replies (of 1 total)
  • Plugin Author Nick Halsey

    (@celloexpressions)

    Thanks for noticing! It actually doesn’t need to (and really shouldn’t) be enabled for IE 9 either, so I’ll put that in (of course there will be debates when ie10 comes out, but I don’t think there are any major issues with 9 that chrome frame solves). I have a translation to release anyway, so I’ll put it in and push the update now.

    Since this tag only does stuff for IE, it is redundant to put it in IE conditionals, of course, but because of validation it looks like it needs to be.

    Update is out, along with several other little issues I just noticed.

Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: Browser Rejector] X-UA-Compatible invalid HTML’ is closed to new replies.