WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Browser Blocker] No settings page after activation

[Plugin: Browser Blocker] No settings page after activation

Viewing 10 replies - 1 through 10 (of 10 total)
  • rfblanchard
    Member

    @rfblanchard

    Tried restarting apache. also tried to access the settings page in a few different browsers. Always got the error above. Let me know if I can provide more details. Thanks

    Plugin Author bdoga
    Member

    @bdoga

    Rfblanchard,

    The problem could have been caused by an incompatibility with another plugin. But beyond that I am not sure what exactly would cause it. if you have (since posting this request so long ago) found the cause for the error, please let me know so I can either correct it in future editions or post a list of incompatible plugins with it.

    lormidorido
    Member

    @lormidorido

    I have the same issue. After installing and activating the plugin I get the same error message and the option page is blank.

    lormidorido
    Member

    @lormidorido

    call_user_func_array() expects parameter 1 to be a valid callback, function ‘BrowserBlocker_Options_Page’ not found or invalid function name in …/wp-includes/plugin.php on line 403

    lormidorido
    Member

    @lormidorido

    these are the plugins I have:
    Blog Copyright (by BTE)
    CMS Tree Page View
    Dynamic 404 Page
    Easy Contact Forms
    Quick Page/Post Redirect DEV
    Simple Fields
    Ultimate Coming Soon Page

    Have you got anyone of these plugins installed rfblanchard?

    rfblanchard
    Member

    @rfblanchard

    no, I don’t have any of those plugins installed. Using Firefox 15 and wp 3.4.1 I still get this error as of today:

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, ‘BrowserBlocker_Options_Page’ was given in C:\Documents and Settings\rblanchard\Sites\wptest1\wp-includes\plugin.php on line 403

    tcsolutions
    Member

    @tcsolutions

    Same error here

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, function ‘BrowserBlocker_Options_Page’ not found or invalid function name in C:\wamp\www\wordpress\wp-includes\plugin.php on line 403

    From apache error log

    PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, function ‘BrowserBlocker_Options_Page’ not found or invalid function name in C:\\wamp\\www\\wordpress\\wp-includes\\plugin.php on line 403, referer: http://localhost/wordpress/wp-admin/plugins.php?activate=true&plugin_status=all&paged=1&s=

    Switched to 2010 theme and disabled all other plugins – same issue. Can’t get to settings page.

    Using wordpress 3.4.2

    fatrod
    Member

    @fatrod

    Also getting this error.

    Plugin Author bdoga
    Member

    @bdoga

    Well, I just released the 0.5.6 version of the Browser Blocker Plugin, unfortunately I have not been able to replicate the issue discussed on this forum, but based on the error feedback I have made some changes to the activation code that I hope will address the issue.

    Please respond and let me know if you are still experiencing the issue or not.

    Hey,

    I had the same issue. It seems you often didn’t open the php parts in your .php files correctly. You used “<?” as opening tag but it has to be “<?php” after changing this in all your files it worked good for me!

    Hope that helps

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: Browser Blocker] No settings page after activation’ is closed to new replies.