WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Browser Blocker] Invalid HTML markup in default blocked screen

[Resolved] [Plugin: Browser Blocker] Invalid HTML markup in default blocked screen

  • Bozz
    Participant

    @bozzmedia

    Ironically, this code doesn’t work very well in IE 🙂 – When I view the blocked message in IE the cursor does not change as you hover over the selections.

    I think you need to use <span> instead <div> if you want to keep things compliant while using anchor tags outside of a box.

    <a href="http://www.firefox.com" title="Download Mozilla Firefox">
    		<div id="firefox" class="browser">
    				<img src="http://www.bozzmedia.com/web/wp-content/plugins/browser-blocker/images/firefox.jpg?9d7bd4" />
    				<center><h2>Mozilla Firefox</h2>
    				<p>made to make the web a better place.</p></center>
    				<img src="http://www.bozzmedia.com/web/wp-content/plugins/browser-blocker/images/download.jpg?9d7bd4">
    		</div>
    		</a>

    http://wordpress.org/extend/plugins/browser-blocker/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Bozz
    Participant

    @bozzmedia

    I went ahead and fixed this. Span did not work properly either on IE6 or IE7, so I simply moved the link tags from outside the browser divs to *within* the browser divs.

    Here is my modified splash.php: http://pastebin.com/JBuL9XbK

    There sexier ways to do this, but I went for a quick fix type approach. Hopefully the developer will see this need and address it in the production version of the plugin.

    Bozz
    Participant

    @bozzmedia

    Thanks for the update for 3.4!

    Any word from the developers on addressing this markup issue? Almost a show stopper bug here, please consider a fix so folks can continue to upgrade.

    Plugin Author bdoga
    Member

    @bdoga

    Bozz,

    Thanks for your feedback and patience, I have been very busy and it has taken me a while to get around to making the simple patch, but Version 0.5.5 has just been released which has included your suggested update to fix the issue with IE6.

    Bozz
    Participant

    @bozzmedia

    You rock, bdoga! Thanks for taking care of this, very much appreciated.

    Plugin Author bdoga
    Member

    @bdoga

    No problem, thank you for taking the time to find the bug and post the suggestion. Much Appreciated!

    drew@drewchristopher.com
    Member

    @drewdrewchristophercom

    I updated to version 0.5.5 and now Browser Block no longer works on IE?
    http://www.belindasdesigns.net

    My settings are:
    Internet Explorer Less Than 8.0
    Internet Explorer Is 9.0
    Internet Explorer Is 8.0

    drew@drewchristopher.com
    Member

    @drewdrewchristophercom

    I figured it out! In order for Browser Blocker to block older IE programs,
    typing just 8.0 did not work. You must put the latest updated version. So I put in 8.0.6001. 18702 and this worked!(this is located in IE, under the Help Menu/About Internet Explorer.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] [Plugin: Browser Blocker] Invalid HTML markup in default blocked screen’ is closed to new replies.