Support » Plugin: Broken Link Checker » [Plugin: Broken Link Checker] Database tables not up to date

  • Resolved Curtiss Grymala

    (@cgrymala)


    Deactivated this plugin the other day while performing the upgrade to WordPress 3.4, then reactivated it. Now, I’m getting an error that says:

    Error: The plugin's database tables are not up to date! (Current version : 5, expected : 6)
    Try deactivating and then reactivating the plugin.Database error : Unknown column 'dismissed' in 'where clause'

    I’ve tried deactivating and reactivating the plugin 3 times already, and it didn’t help. Any suggestions?

    http://wordpress.org/extend/plugins/broken-link-checker/

Viewing 3 replies - 1 through 3 (of 3 total)
  • I’m not sure if you’ve already seen these or not, but it looks like there’s a couple of notes in the plugin info and changelog that might be relative to the issue.

    From the changelog: 1.6.1 “Fixed the “database not up to date” bug. Now the plugin should properly upgrade the DB”

    ..and a note from the author about upgrading the plugin:

    “To upgrade your installation

    Deactivate the plugin
    Retrieve and upload the new files (do steps 1. – 3. from “new installation” instructions)
    Reactivate the plugin. Your settings will be retained from the previous version.”

    I went ahead and deleted and reinstalled the plugin, and that seems to have fixed the “database” error. Thanks.

    You’re welcome.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: Broken Link Checker] Database tables not up to date’ is closed to new replies.