Support » Plugin: PageMenu » Plugin Broken by WordPress5.5

  • Since I updated to wordpress5.5 I’ve been having issues with many of my plugins needing to update their code. The error is reported as “jquery.fn.live() is deprecated”.

    In the meta-template.php file in this plugin, on line 90…

    This line:
    jQuery(‘.menu-item-has-children input[type=checkbox]’).live(‘click’, function() {

    Needs to be edited to:
    jQuery(‘.menu-item-has-children input[type=checkbox]’).on(‘click’, function() {

    This edit seems to have corrected my issue.
    Maybe it will help- with yours too.

    Goran

Viewing 3 replies - 1 through 3 (of 3 total)
  • I verify LordGoran’s statement

    according to jQuery documentation

    Note: This API has been removed in jQuery 1.9; please use on() instead.

    Zarausto

    (@zarausto)

    Hello Author, jQuery().live must be changed to jQuery().on as WordPress stopped support do jquery-migrate on versions 5.5+

    This is causing block to plugins like WpBakery.

    Quick fix:
    example.com/wp-admin/plugin-editor.php?file=page-menu%2Fmeta-template.php&plugin=page-menu%2Fpagemenu.php

    On line 90 change:
    jQuery(‘.menu-item-has-children input[type=checkbox]’).live(‘click’, function() {
    to
    jQuery(‘.menu-item-has-children input[type=checkbox]’).on(‘click’, function() {

    I had the same problem. @zarausto fix solved it perfectly. Thank you! Let’s hope the author fix it too in the next update.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Plugin Broken by WordPress5.5’ is closed to new replies.