Support » Plugin: List category posts » plugin broke with WordPress or plugin upgrades

  • I have had some pages working fine with this plugin generating a list of custom port types. The page coding has not changed but the lists generated are now all empty. It appears that all custom post types generate empty lists now, even though there are posts of those types, but posts of standard types “standard” posts for instance are non empty. I recently upgraded the “Custom Content Type Manager” (CCTM) plugin. Not sure if that is what broke things. Anyway I would like some help in debugging the issue. I don’t have the option of rolling back the whole system and don’t want to manually role back the CCTM plugin as there may be changes to the database from updating the plugin.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The same thing happened for me.
    I have been using List Category Posts (LCP) for some time now to supply lists of post titles on a page and somet time in the last couple of months the [catlist….] calls are returning nothing. Like @rolyatnitram, I have updated many plugins and perhaps added one or two so it is difficult to tell what is causing this problem. Are others having this problem as well?
    Here is the URL of the page I usually use it on with the blank lists:

    Plugin Author Fernando Briano


    Uh, this is bad. What version of WordPress are you using? What’s the code?

    Can you set debug=true on your WordPress installations and check for warnings or errors related to the plugin?

    In my case the list stopped working after upgrading the version of the plugin used to create the custom types = “Custom Content Type Manager” (CCTM). I upgraded that from to the latest = After that broke the catlist function I rolled back the upgrade and it worked again. Haven’t resolved the issue yet. Living with the older version of CCTM.


    Interesting, I did just add the Types plugin (from which sounds similar to the plugin @royalnitram describes. I will look into enabling debugging in the next couple of days to do more research. @PicandoCodigo, it would be great if you could help us resolve this!

    Ok, I followed the instructions to set debug to true by doing the following in wp-config.php….

    define('WP_DEBUG',         true);
    define('WP_DEBUG_DISPLAY', true);
    define('WP_DEBUG_LOG',     true);

    and I tried loading the page in question and still no errors or apparent warning returned. I have looked through the log for the last couple of days and also don’t find anything apparently related to the plugin.

    Plugin Author Fernando Briano


    Oh, then this must be some issue with the plugins you mention. They must change the way custom posts are stored or something. Maybe we can get some help from the plugin developers by posting a report on the plugin’s forum?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘plugin broke with WordPress or plugin upgrades’ is closed to new replies.