Support » Plugin: Social Media Share Buttons » Plugin broke website when disabled? “Error establishing a database connection”

  • I had used this plugin for quite a while. I like the appearance of it, but two problems are causing me to give it 1 star.

    #1: The plugin caused the text “Share List” to appear in article excerpts in my theme and possibly on search engines too. The social media share buttons or some element of this plugin seems to have some ALT / descriptor text that contains “share list” and for some reason it’s picked up in the excerpt because that “text” is at the start of every post. In the past I fixed this by searching through the plugin and deleting the “share list” text, so it should be a simple fix. But when I updated the plugin the problem returned.

    #2: The plugin completely broke the entire website when I disabled it. Caused a database connection error and I couldn’t access anything on the website, even the WordPress login. The website was working fine, then all I did was disable the plugin then refresh the site–suddenly got database errors for the entire site. So I logged into my site via FTP and deleted this plugin directory and that instantly fixed it. Not sure why that happened, but if a plugin breaks the entire site that is obviously unacceptable.

    If these issues are fixed in the future I may check back in with the plugin and update the review, but as-is it is un-usable.

    • This topic was modified 11 months, 1 week ago by daydull.
  • The topic ‘Plugin broke website when disabled? “Error establishing a database connection”’ is closed to new replies.