Support » Plugin: Add Polylang support for Customizer » Plugin Broke the site!

  • Resolved leslieoneonone

    (@leslieoneonone)


    Hi! I was trying to deactivate plugins to test the contact form, but then the whole site broke, and I contacted WordPress via chat, they said the issue was caused by “Add Polylang support for Customizer” plugin.

    They had to deactivate the plugin to fix it, and suggested I report this issue to the plugin creator.

    My site is in two languages. The primary English site is still here, and since I can’t activate the plugin, I have lost the Chinese site! Can you debug the plugin and will that fix the problem? How can I retrieve the Chinese site?

    Leslie

Viewing 6 replies - 16 through 21 (of 21 total)
  • Thread Starter leslieoneonone

    (@leslieoneonone)

    Hi @richardevcom

    Polylang is installed and activated Version 2.8.

    Where can I find the folder?

    There’s also one thing, I also have Locotranslate activated but I don’t use it, could this be why?

    Could you so kindly maybe take a look inside my site if it helps us to fix this?

    Leslie

    Plugin Author richardevcom

    (@richardevcom)

    The versions are definitely supported. But what catched my eye, is that the folder/file is missing, which well.. it shouldn’t

    Via FTP.

    No, I have Loco Translate installed myself and it works fine. Previous issue was indeed our fault, but this error may be caused by manually edited WordPress or Polylang files.

    @leslieoneonone please write to me via [removed] and let’s chat via Discord or Skype.

    • This reply was modified 1 year, 3 months ago by richardevcom.
    Thread Starter leslieoneonone

    (@leslieoneonone)

    Hi @richardevcom ,

    Let me write to you now 🙂 Thanks so much!

    Leslie

    Plugin Author richardevcom

    (@richardevcom)

    Allright, for those who experienced the same issue – this was due to using multisite WP. I worked around this with an ugly fix of require __DIR__ . '/../../polylang/include/api.php'; in class-apsfc.php on line 84 so both single and multi sites can include Polylang API.php from subparent plugin folder.

    This can broke sites too.
    If you have polylang pro who can be stored in “plugins/polylang-pro”.
    Can you add somes file check before puting a require ?

    Plugin Author richardevcom

    (@richardevcom)

    @bmartinent already done in newest version. Update yours.

Viewing 6 replies - 16 through 21 (of 21 total)
  • The topic ‘Plugin Broke the site!’ is closed to new replies.