BP Group Documents
[resolved] Plugin breaks WP with Buddypress install (5 posts)

  1. Bryan
    Posted 2 years ago #

    I was running the plugin for a while until I noticed it just stopped working. I just tried to update to the latest version and it broke the site. Shows a blank page on the front end. Thankfully I was still able to access the back end. First did it with 3.5.2 and then with 3.6. The only way to fix it is to delete the plugin and repair my DB tables. Very frustrating.


  2. breity10
    Posted 2 years ago #

    I'm having a similar problem. Whenever I try to activate BP Group Documents, I get this error:
    "Fatal error: Call to undefined function get_home_path() in /PATH-TO-MY-WP-INSTALL/wp-admin/includes/misc.php on line 128"

    I then have to either remove or rename the plugin folder (which deactivates the plugin) to fix the problem. Any insights? I'd really like to get BP Group Documents up and running for our BP community. Thanks!

  3. mort3n
    Posted 2 years ago #

    Hi @breity10

    The function get_home_path() is defined in wp-admin/includes/file.php


    So, I suggest you verify that you have this file in your installation. It's WP core, so it should be :-)

    Hope this gets you started.


  4. mrjarbenne
    Posted 2 years ago #

    I think our two forum posts are related. I've erroneously titled mine "Plugin Conflict with WPML" http://wordpress.org/support/topic/plugin-conflict-with-wpml?replies=2 where I should have perhaps titled it wp-admin/includes/misc.php error, because besides yourself, there seem to be a few different reports of issues involving this plugin and that error:

    My Post
    Your Post
    This Post: http://wordpress.org/support/topic/fatal-error-when-activating-plugin-10?replies=15#post-4587614

    BP Documents seems to be the common thread, although the order in which you enable the plugins seems to be a suggested fix in some cases.

  5. lenasterg
    Plugin Author

    Posted 2 years ago #

    I believe I have fixed it at version 1.3.
    Please give it a try and let me know if it works.

    Thanks for submitting the bug.


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • BP Group Documents
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.