Support » Plugin: Yoast SEO » Plugin breaks the customizr

  • Resolved Daniel Mesteru

    (@daniel-mesteru)


    Hello,

    I have problems using Yoast SEO after upgrading to WP latest version (4.9).
    Behaviour:
    I have Yoast installed on my dev site on localhost. When activated and I’m trying to open the WP Customizer the following error appears on frontend:

    “localhost redirected you too many times.” and the page is blank printing this error in center.
    After some trial and error I’ve discovered Yoast being the culprit for this issue (revert to the default theme, enabled just Yoast plugin and disable the others, etc.)

    Yoast version: 5.8
    WP version: 4.9
    Woocommerce version: 3.2.4
    PHP vers.: 5.6.20
    Environment: Apache on XAMPP localhost
    Theme: OceanWP

    Please help. 🙂

    Thanks,
    Daniel

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Pcosta88

    (@pcosta88)

    Hi Daniel,

    We would like some more information.

    1. Are you a Yoast SEO Premium user? If so, please know you are entitled to premium support at support@yoast.com. However, in regards to your issue it appears to be a redirect loop.

    A redirect loop happens when pages are entered in the SEO->Redirect in such a manner as to eventually have the page be redirect back to itself. To resolve the issue, you should search in the SEO->Redirect section for the page in question and then delete the redirects. This will then break the redirect loop. This guide explains more: https://kb.yoast.com/kb/page-redirects-unexpectedly/

    2. If not a premium user, does clearing your caching from your plugin, theme, server, browser, or CDN such as Cloudflare resolve the issue? If you are not sure how to clear your server caching, please speak with your host provider. This guide explains more about how to clear browser caching: https://kb.yoast.com/kb/how-to-clear-my-browsers-cache/.

    3. If you go to SEO-Advanced-Permalinks and select “no redirect” in the “redirect ugly permalinks” feature does the issue resolve?

    4. If you switch to a different browser such as FireFox or Chrome does the issue resolve?

    • This reply was modified 1 year, 11 months ago by  Pcosta88.
    • This reply was modified 1 year, 11 months ago by  Pcosta88.

    Hello,

    3. This was it. I’ve disabled the redirection from Yoast advanced section and the WP Customizer is working ok now.
    Thank your for your quick reply. I can’t believe I’ve forgot this option activated. Sorry for the trouble.

    Regards,
    Daniel

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Plugin breaks the customizr’ is closed to new replies.