Support » Plugin: Email Encoder - Protect Email Addresses » Plugin breaks Stripe functionality on WooCommerce

  • Resolved Mario

    (@mm2103)


    With activated Email Encoder plugin, the Stripe functionality in WooCommerce checkout is broken. In the first place, the following string is displayed on the “payment ofter invoice” Page: “data-full-name=”” datacurrency=”eur” > right after the green lock symbol.

    When confirming the payment via credit card, the following message is displayed and the payment cannot be made: Invalid email address, please correct and try again.

    Looks like stripe needs a valid email address but cannot receive it because of the encoding. When deactivation Email Encoder, everything works fine.

    The error appears on the WooCommerce payment page that will be reached by the invoice link, not the main payment page in the checkout.

    I’m using Email Encoder 2.0.3, WordPress 5.2.4, WooCommerce 3.8.0, Stripe for Woocommerce 4.3.0

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Ironikus

    (@ironikus)

    Hi @mm2103 – thank you a lot for your message, as well as for mentioning the issue.
    Do you have any staging site available where I can check against that issue?
    In case you have, feel free to reach out through our website for more tailored support. 🙂
    Thank you already a lot.

    Mario

    (@mm2103)

    I’m sorry, this is a live site and currently I don’t have any staging to offer

    Plugin Author Ironikus

    (@ironikus)

    Hi @mm2103 – thank you for your answer.
    I will set up a test system for further testing and come back to you after my tests.

    Plugin Author Ironikus

    (@ironikus)

    Hi @mm2103 – I wanted to give you a quick heads-up on this topic.
    We now extended our plugin with a feature that filters all HTML attributes with soft-encoding.
    This feature is currently in our beta-release and should solve your problem.
    I created a new version for you, which you can use to test if your issue still occurs after.
    Feel free to download it here: https://www.dropbox.com/s/7pp6lfld2lg3ulm/email-encoder-bundle-beta.zip?dl=1
    If it solves your problem, you can continue to use it – no further action needed (simply update when we officially release the new version)
    In case you have further questions, feel free to reach out at any time.

    All the best
    Jannis

    Plugin Author Ironikus

    (@ironikus)

    Hi @mm2103 – I just wanted to inform you that we launched a new version now, which also addresses the mentioned issue.
    Feel free to reach out in case you have further questions.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.