Support » Plugin: Add Polylang support for Customizer » Plugin breaks on activation

  • Resolved stormymondays

    (@stormymondays)


    I just installed the plugin and it creates a fatal error.

    I can see this in the error log:

    PHP Fatal error: Cannot redeclare pll_the_languages() (previously declared in /home/USERNAME/public_html/wp-content/plugins/polylang/include/api.php:31) in /home/USERNAME/public_html/wp-content/plugins/polylang-pro/vendor/wpsyntex/polylang/include/api.php on line 34

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author richardevcom

    (@richardevcom)

    Hi @stormymondays Looking at the error I’m pretty sure you’re using both free and pro version at the same time, as they both are trying to declare the same function. Oour plugin doesn’t declare any of these functions so it’s not our plugins issue. Try deactivating free version. The error should disappear.

    If it’s not the case and error still appears – please follow our “Read before post” guideline and share more information about this error.

    • This reply was modified 4 months, 1 week ago by richardevcom.
    • This reply was modified 4 months, 1 week ago by richardevcom.
    Thread Starter stormymondays

    (@stormymondays)

    Thanks for the quick reply! No, I don’t have the free and pro version at the same time, the free version is inactive. I do have Polylang for WooCommerce active, but that is necessary.

    I’m on the latest version of everything and I have 54 plugins enabled. The fatal error appears when enabling your plugin and stops when I move it out of the plugins folder (because it locks me out of everything).

    Plugin Author richardevcom

    (@richardevcom)

    Can you please confirm by disabling all plugins, but single Polylang plugin and then enabling our plugin?

    @stormymondays allright. I will test single Polylang version with this. It may be due to requiring api.php and once it is required the functions are registered before Polylang calls the file and registers them in some occasions.

    • This reply was modified 4 months, 1 week ago by richardevcom.
    Plugin Author richardevcom

    (@richardevcom)

    @stormymondays I indeed found the issue on our side. Thank you for submitting this issue. 🙂

    It has been fixed now and submitted, so you should go and update our plugin to 1.4.0 version.

    • This reply was modified 4 months, 1 week ago by richardevcom.
    Thread Starter stormymondays

    (@stormymondays)

    Many thanks for the speedy fix!

    Plugin Author richardevcom

    (@richardevcom)

    You’re always welcome @stormymondays
    I would appreciate if you’d leave a review of our plugin. 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.