Support » Plugin: Smart Slider 3 » Plugin breaking WordPress features

  • Resolved 21cscott

    (@21cscott)


    I’m working on recreating a school’s website and your slider plugin works great for the full-width home page slider I was looking for! There are a few problems that occur when I activate this plugin, also keep in mind that I’m using my own custom theme and this is the first time that I’m creating a theme so that could be a possible reason why this isn’t working.

    When I go to my “news” page which is the page where all of the posts are displayed, the page displays this: https://prnt.sc/104u9fy

    As soon as I disable the Smart Slider 3 plugin, it works fine. One other error I have is when I try to click on “customize” under the appearance settings I also get an error message here: https://prnt.sc/104ubib
    Also, this error goes away when I disable the plugin.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Support Laszlo

    (@laszloszalvak)

    Hi @21cscott

    The error messages appearing in your screenshots are just general error messages which indicate that there is either a PHP error or a server error, e.g. when a server limitation is being reached.

    To find out the actual problem, you should enable error reporting on your site over your wp-config.php like we suggest here:
    https://smartslider.helpscoutdocs.com/article/1949-error-reporting#error-wp
    Then you should go to the pages where you can see the problem occur and refresh the page.
    This will generate an error log. If you did the way it is suggested in the documentation, then the error log will be called “php-error.log” and it will appear in the same folder where your wp-config.php is located.

    I could imagine that the problem is may related to a memory limit problem. If it is then you may find an error in the log something like: “Allowed memory size of 67108864 bytes exhausted”. If this is the case, then you or your host should increase the memory limit as we suggest here:
    https://smartslider.helpscoutdocs.com/article/1736-common-server-errors#memory_limit

    If you can not find such error in the error log, and you can not identify the problem either, then feel free to open a support ticket here:
    https://smartslider3.com/contact-us/support/?ref=https://wordpress.org/support/topic/plugin-breaking-wordpress-features/
    and send us a link where we can check your error log.

    Best regards,
    Laszlo.

    Thread Starter 21cscott

    (@21cscott)

    Hey @laszloszalvak

    It most definitely isn’t the memory limit, I can see the site is only using about 20% of the total ram usage. I created the wp-config.php and added the code you suggested but I’m still not getting a file generated to show the errors. I could open a ticket but not sure how useful that’ll be for you without access to the error log.

    Thanks for the quick response and sorry for the late reply. Please let me know if you have any other suggestions and I appreciate the help!

    Here is a screenshot of my wp-config.php. I followed along with the article you sent but it doesn’t seem to be working. https://prnt.sc/105oj96

    Plugin Support Laszlo

    (@laszloszalvak)

    Hi @21cscott

    In your screenshot, it seems as if this wp-config.php file would be located inside your theme’s folder, but the real wp-config.php file should be located in the root folder of your WordPress installation, where you can find the folders like “wp-admin”, “wp-content” and “wp-includes”.
    That is the file where you should actually add the code to enable the error reporting.

    Note: the WP_DEBUG constant is usually already defined there with false value, so you don’t need to add that again, you just need to modify its value to true.

    If you still can not see any errors after making these modifications and checking the page with the problem, then please open a support ticket:
    https://smartslider3.com/contact-us/support/?ref=https://wordpress.org/support/topic/plugin-breaking-wordpress-features/
    and we will check this problem on your site.

    Thread Starter 21cscott

    (@21cscott)

    @laszloszalvak
    Thank you! Yes I know see these two errors.

    Fatal error: Out of memory (allocated 29360128) (tried to allocate 65536 bytes) in /home/dcts/public_html/dcts/wp-content/plugins/smart-slider-3/Nextend/SmartSlider3/Platform/WordPress/Integration/Gutenberg/Gutenberg.php on line 14

    Fatal error: Out of memory (allocated 29360128) (tried to allocate 65536 bytes) in /home/dcts/public_html/dcts/wp-includes/class-wp-fatal-error-handler.php on line 40

    My memory usage is about 60%, is this a setting with the plugin or do I need more memory for the server?

    Plugin Support Ramona (from Nextend)

    (@nextend_ramona)

    Hi @21cscott

    This error message means that the memory limit on your server was reached. Contact your host and ask them to increase it.

    Smart Slider 3 requires at least 64MB of memory:
    https://smartslider.helpscoutdocs.com/article/1716-system-requirements
    but your site might need much more, depending on the amount of plugins you have.

    Try to ask your host to double the memory_limit (e.g. if you have 64MB now, ask them to set it to 128MB).

    Thread Starter 21cscott

    (@21cscott)

    @laszloszalvak

    I fixed a different error that was printed after enabling WP_DEBUG.

    I still get this same error on my “news” page which is the posts page.

    Here is a link to the page. https://www.mydcts.org/dcts/news/

    Thread Starter 21cscott

    (@21cscott)

    Hey @laszloszalvak

    The server has 2GB of RAM, after restarting the server I no longer get this error. Though I still am having issues with the news page. As soon as I disable your plugin it works fine.

    Here’s a screenshot of the memory, it hasn’t gone over 70% usage. https://prnt.sc/105v0bd

    Plugin Support Ramona (from Nextend)

    (@nextend_ramona)

    Hi @21cscott

    This error message:

    Fatal error: Out of memory (allocated 29360128) (tried to allocate 65536 bytes) in /home/dcts/public_html/dcts/wp-content/plugins/smart-slider-3/Nextend/SmartSlider3/Platform/WordPress/Integration/Gutenberg/Gutenberg.php on line 14

    Happens because your server’s memory limit was reached. If it’s indeed set to 2GB then something is limiting it down. Create an info.php file:
    https://smartslider.helpscoutdocs.com/article/1736-common-server-errors#memory_limit
    and check the value of the memory_limit. If it’s not the 2GB that’s supposed to be set, contact your host about this problem, because there will be some kind of misconfiguration.

    Thread Starter 21cscott

    (@21cscott)

    https://www.mydcts.org/info.php

    Yes, you would be correct. Thank you so much for your help once again. I’ll have to get in contact with them and I’ll keep you updated!

    Thread Starter 21cscott

    (@21cscott)

    Alright, so I got the memory_limit changed to 2G. That did fix the issue where I couldn’t use the customization under appearance in WordPress, this must’ve been due to the memory limitation.

    I’m still having an error with the news page. I’ve enabled DEBUG though I cannot find the error logs files. I checked both in the wp-contents folder and also in the root folder.

    Plugin Support Ramona (from Nextend)

    (@nextend_ramona)

    Hi @21cscott

    If you switch to a default WordPress theme (like Twenty Twenty) and turn off all plugins but Smart Slider 3, does your News page load?
    If it loads like that, start turning on all your plugins and see if you can enable them without seeing the problem again.

    If everything is fine using a default WordPress theme then the problem happens because of the theme. Check the Theme Developer Handbook:
    https://developer.wordpress.org/themes/
    and make sure your theme follows the best practices.

    Thread Starter 21cscott

    (@21cscott)

    Yes, it works then. It’s something with my theme I guess I need to figure it out.

    I won’t be working on this until tomorrow. My shift is over. Thanks, @nextend_ramona and @laszloszalvak for all the help today. I appreciate it and I think I’ll be able to use this plugin once I figure out this final issue.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.