Support » Plugin: Transposh WordPress Translation » Plugin breaking language

  • Hi @oferwald

    I really love your plugin edit functionality, this is awesome.
    I am close to finish my website, I just end up facing a bug with an other plugin called Geomywp.
    The language is broken when I clic on the form’s submit button.
    I tried w3c validator and found an error like « the action form can not be empty ». But, this is also the case in another form wich is not breaking the language so this might not be the reason.
    The other form is BP search, visible from the page « membres » of my website.
    Here you can submit once and keep the language. However, if you clic search a second time, you also loose the language ..

    I don’t know how I could keep the ?lang=XX when I submit Geomywp form. It doesn’t look like a big issue.
    I tried placing your script in the footer but that is not working either.
    I suppose their is something to add in the code somewhere.

    Can you help me please ?

    Many thanks for the great work you have been doing so far.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi !

    I found 1/2 solution !! 😀
    That was somewhere on a forum, a similar case with woocommerce.

    Here is the code for geomywp :

    add_action('gmw_post', array(&$this, 'gmw_post'));
    
    if (isset($_GET['action']) && $_GET['action'] == 'gmw_post') {
    $this->target_language = transposh_utils::get_language_from_url($_SERVER['HTTP_REFERER'], $this->home_url);
    }

    Now the page result keeps the language, however the “lang=XX” is not present in the adress bar. And any change on the page breaks the language.
    For exemple, if I change the number of results shown per page (dropdown option), the language falls back to default. Same if I initiate a second search. Same if I go to the next pages of results.
    But, if i tick the “edit translation” box, this puts the lang in the url. When I untick it, the lang stays in the url. Then I can use the “number_of_results_per_page” dropdown, the language is kept. The solution is the “lang=XX” missing in my search results url.

    How can I get the lang in the url please ?

    • This reply was modified 1 year, 11 months ago by gingerbooch.

    Hi,

    New input. If I use the URL re-writing, site.com/XX/ instead of site.com/?lang=”XX”, I have no more trouble with the GeoMyWP search. Everything goes fine, I can change the number of restults per page, I can go to the next page, that never breaks de language.
    But, I am using 3 plugins. The third one is Buddypress, and the URL re-writing does not work with BP links like profile link, registration link. It seems to loop.

    Is it possible to use buddypress with url rewriting ? My foreign languages can’t access BP links with that config ?

    Any idea for this issue or for the previous one to keep the markings in the url ?

    Hi @oferwald,

    Any idea please ? 🙏

    • This reply was modified 1 year, 10 months ago by gingerbooch.

    Hi there,

    I am still looking for a solution.

    ?lang=xx - does not work with GeoMyWP
    /xx/ - does not work with BuddyPress

    Thank you

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Plugin breaking language’ is closed to new replies.