Support » Plugin: Breadcrumb NavXT » [Plugin: Breadcrumb NavXT] PHP version error message

  • Resolved Josh Leuze


    Hi John, I was using Breadcrumb NavXT 3.7.0 on my local dev setup and uploaded it to a server that is using PHP 5.1.6 and ran into this error:

    Your PHP version is too old, please upgrade to a newer version. Your version is 5.1.6, this plugin requires 5.2.0

    I have a bunch of plugins installed on this site and it took me a bit to figure out which one was giving me this error. Might I suggest including the name of your plugin in this error?

    Glad to see how well Breadcrumb NavXT is supporting custom post types and taxonomies, it’s been a big help on some recent projects!

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author John Havlik


    Hi Josh,

    Yeah, I’ve been playing around with that code lately. In the SVN Trunk it will now deactivate the plugin automatically, if is_admin() evaluates as true (or to put it another way, the deactivate_plugins() function is available). I added the plugin name in the error, it’s in the SVN Trunk right now.

    Not to be preachy, but PHP 5.1.6 is over 4 years old. Also, you probably should deactivate plugins before updating them. I know I don’t do it this way on my testbed (testbeds are for breaking stuff), but on live sites it’s usually a good idea (plus Breadcrumb NavXT usually needs a deactivation/activation cycle to do settings upgrades between versions, though there are ways around this now).

    Anyways, this is related to:

    I wasn’t updating the plugin, my local dev setup has PHP 5.2 so the plugin was running fine while I was developing the site. It was when I migrated the site to a live server with an older version that I got the error, so that probably a pretty fringe case.

    This is actually the second time I’ve ran into this with a plugin. But I’m not about to downgrade my local setup, so hopefully when WordPress starts requiring 5.2 it will force more webhosts to quick slacking!



    I hit the same problem, it rendered the whole site useless. Had to downgrade to v1.6.0. Unfortunately upgrading to PHP 5.2 is very difficult as I’m dealing with a legacy Fedora 3 machine



    This plugin is always breaking my Blog. It’s done it more than once before but never with such catastrophic consequences as locking me even out of my control panel so I couldn’t disable it. I had to connect by ftp and delete the breadcrumb folder to get back into my control panel and restore my blog.

    Plugin Author John Havlik


    This plugin is always breaking my Blog. It’s done it more than once before…

    How? Do you have an example? Without an example there is nothing I can go on to attempt to resolve the issue. As for requiring PHP5.2, I am not backing down on the requirement, and have made some improvements to the message per my reply to JLeuze above. These will be in 3.8.0, but by then you might as well get your host to install a version of PHP 5.2 or even better PHP 5.3.



    Hello mtekk. I upgraded it once before and my Blog just displayed a blank page. It turned out that the code had been changed and I had to move the lines of code calling the script from its previous place to another location to get it to work.

    Regarding this present incident, I wouldn’t object to you requiring any version of php, or even changing things within the code that made it only work under ridiculously rare circumstances. It’s a free plugin and I find it very useful but you can change it however you like. My objection is if an author changed criteria so that when their users update it, it doesn’t just not work but it completely brings down the Blog. I couldn’t even get back into my control panel to disable the plugin and if I hadn’t thought to use ftf to delete the breadcrumb folder I would have been left without a working Blog.

    I can only assume it was an unexpected situation from your point of view and surely the plugin isn’t deliberately written knowing it will cause a fatal error if it can’t find the “right” version of php? I thought error handling in software allowed contained reactions to not finding the right environment to run in?

    I can only assume you had no idea the blog would be brought down if the wrong php version was installed or otherwise you would have not allowed the plugin to install unless it had checked for the right version first or at least warned people not to update it unless they had checked they were running the later php version. I updated it using automatic update.

    Plugin Author John Havlik


    How long ago was it when you had to move the calling code? I do not remember anyone else having issues with the location of the calling code, except for a brief period of time when placing the calling code within the loop caused issues.

    The entire “lock out” issue, as I stated earlier, and in the other thread you replied to, was an unintended consequence. WordPress’ behavior on plugins that throw errors, or die on activation seems to be non-ideal to say the least (IMHO it should auto deactivate unless in debug mode).

    Finally, when you said

    I’ve now had V5.2.16 installed and get exactly the same error

    in the other thread, what exactly did the message/error say?



    Hello mtekk: Thanks for your response. It was a year or two back. I think it was not long after I’d started using it and there was an update. I said previously that the earlier incident caused a blank page but I should have said it caused my header and sidebar to be displayed but no content. If you didn’t get any other reports it may have been something peculiar to how I had it installed or my wordpress skin. All I remember was I had to move the calling code somewhere else.

    I apologise for using the phrase “always breaking my blog”, I was a bit angry at losing my blog. As it is a major part of my livelihood I get quite stressed if it goes down.

    Regarding this current issue if it is WordPress’s fault it’s a very serious bug that needs fixing. As I said before surely the number one thing to be avoided is for a Blog to be taken offline.

    I contacted my hosting company and they said –

    “5.1.6 is an old verison in upstream terms. However it is the chosen version for CentOS 5 to distribute. Because CentOS versions are released and supported for 5 years, towards the end of their life the default versions of applications may seem old, but are kept up
    to date security wise by back-porting bug fixes.

    CentOS 6 is due out in the next few months which will distribute PHP 5.3.x, but again this will be supported for 5 years, and will seem out of date by the time we get to 2015!”

    I don’t know if that’s true or not but if so there could be a lot of people with an old version of php.

    When I received the message “I have upgrade PHP which is now at version 5.2.16.” I tried breadcrumb again and exactly the same thing happened. I just got a blank page with the same warning that my php version was too old and had to delete the breadcrumb folder again. I wondered if was somehow a caching issue but I tried reloading my blog with a control + refresh.

    I think this plugin is one of the essential plugins and I don’t like being without it.

    Plugin Author John Havlik


    Well the blank parts of a page thing could have been the bug when the plugin was called in the loop. That should be fixed now.

    It sounds like your hosting company doesn’t like to do software updates after installing the OS off of a disk. CentOS has a wiki page for updating PHP to 5.2.x and it is quite simple:

    # rpm -qa |grep php
    # yum update
    # service httpd restart

    The first checks for installed php components, the second does the install, the third restarts apache.

    I noticed one thing with the checking code, I look at the superglobal PHP_VERSION for the check, but report using phpversion(). If after updating you get where it says a version over 5.2 in the message (e.g. the warning becomes non logical), then it may be something with the global.

    The message should have contained two version numbers in it, like the example JLeuze posted:

    Your PHP version is too old, please upgrade to a newer version. Your version is 5.1.6, this plugin requires 5.2.0

    Where “5.1.6” would be what ever version of PHP your site is running. If that is blank, then your host is trying to hide their PHP version. If that version is still 5.1.x or 5.0.x (where x is a number), then your host lied to you about upgrading the PHP version. If that version number is 5.2.x (where x is a number), then as explained above, PHP_VERSION and phpversion() are for some reason two different versions (and something I need to look into).



    Hello mtekk: I just restored the breadcrumb plugin folder and reactivated the plugin, which I’m glad to report now works ok. I can only assume there was some delay between them sending me the email telling me the php was upgraded and me actually using it.

    I agree that 5 years seems a ridiculously long time to keep a version although they say they keep it up to date with security upgrades. I don’t know how much php changes but clearly things do normally function ok with a 4 year old version as your plugin is the only issue I’m aware of on all my sites and Blogs.

    It still seems a risky thing to make the plugin require a pretty up to date php version as there must be many with older versions but I’m glad to have the plugin back because I think it’s useful and good for seo to have a breadcrumb trail.


Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: Breadcrumb NavXT] PHP version error message’ is closed to new replies.