Support » Plugins and Hacks » [Resolved] [Plugin: BP My Home] Oops, error while unzipping!

[Resolved] [Plugin: BP My Home] Oops, error while unzipping!

  • Hi,
    Thanks for a great looking plugin.
    However, I am having a problem with install – which is unusual.

    BP V1.5.4 on WP 3.3.1.

    Upload your plugin (and widget zips). Activate. no prob.
    Go into BPMH Manager – click to ‘Install widgets’ (any of them) – gives message:

    “Oops, error while unzipping!”

    – asks me for ftp pwd – which i supply. It then says ‘widget activated. though it still appears in list for activation!

    go to front-end BP ‘My Home’ of logged in user – it says:

    Admin forgot to activate at least 1 widget, if i were you i would contact him to make him move !

    tried repeating for all/any of widgets – same result – no widgets.

    i’m sure its not meant to work like this.

    can you help?



Viewing 2 replies - 1 through 2 (of 2 total)
  • some further info regarding this problem:

    1) checking what it had and hadn’t done:

    – directories:

    – created ok, BUT have perms only 766 whereas all other subdirs in upload are set at 777.

    this may or may not be a problem.

    2) tracing though the code:

    file: bp-my-home-admin.php,
    function: bpmh_unzip widget

    – last line – return from call to wp unzip_file is:

    error message = “Incompatible Archive”
    error: code = incompatible_archive
    error data = PCLZIP_ERR_MISSING_FILE (-4) : Missing archive file ‘/var/www/vhosts/mysite.com/httpdocs/wp-content/plugins/bp-my-home/zip-widgets/’

    so it looks like it has some sort of permissions problems copying across zip files into the directory the plugin has created for itself.

    – maybe related to the way my system is set up, but possibly a bug anyway?

    another solution is to unzip the widgets archive locally then use your ftp account to drop them in /uploads/bpmh-widgets

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] [Plugin: BP My Home] Oops, error while unzipping!’ is closed to new replies.