WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: BP Member Filter] Can’t get this to work

[Resolved] [Plugin: BP Member Filter] Can’t get this to work

Viewing 4 replies - 1 through 4 (of 4 total)
  • I realise this is only a day or two old but BUMP.

    Ok one week past and still no reply. This either means my original post was so moronic it doesn’t deserve an answer or it’s a good reason that this plugin shouldn’t be used. Personally all from column B.

    Bumpety BUMP BUMP BUMO.

    Ok some progress. After upgrading to latest version of Buddypress (released the other day) I got an error “expected to be a reference value given in” in plugin.php.

    A quick search through bp-member-filter.php reveals line 265 where the function causing the error is called:-
    function bp_replace_members_filter( $has_members, &$members_template ) {

    Removing the ampersand fixes the problem, don’t ask me why as I haven’t programmed in over 10 years and am not overly familiar with PHP anyway.

    To spell it out the line should read:-
    function bp_replace_members_filter( $has_members, $members_template ) {

    So pros:-

    It does work with some fettling.

    It beats writing your own search function from the ground up.

    Cons:-

    No one seems to be able to support the plugin (the author is awol as far as forums are concerned).

    The documentation doesn’t go nearly far enough.

    It won’t work with check boxes (yet) so have had to change a field to radio button (and temporarily change back if user profile needs changing)

    Yeah I second that,

    I saw:

    PHP Warning:  Parameter 2 to bp_replace_members_filter() expected to be a reference, value given in snip.../wp-includes/plugin.php on line 166, referer: snip.../members/

    so duly went and removed the ampersand and, hey presto, filtering sort of works as long as I use a select box rather than a multi select box.

    Trouble is, I don’t know if there are any other side effects to this change.

    Also, the plugin author suggests that this is not the place for such discussions, so hopefully the discussion will continue over here:

    http://buddypress.org/community/groups/third-party-components-plugins/forum/topic/bp-member-filter/

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] [Plugin: BP Member Filter] Can’t get this to work’ is closed to new replies.