Support » Plugin: BP GTM System » [Plugin: BP GTM System] Sub Tasks not working for me

  • marbler


    Hi folks,

    When I enter a sub task, it always just becomes a task and is never associated with the original task I clicked “Add Sub Task” on.

    When I go back to edit the ‘sub’ task it then gives me the option of which project to associate it with (which is doesn’t when I originally set up). I do this, but it is still not associated with a higher level task.

    I am using the latest versions of the plugin and IE9.


Viewing 5 replies - 1 through 5 (of 5 total)
  • fitninja


    The “Subtasks” feature isn’t working for me either. My subtasks aren’t being recognized as subtasks and are not associated with the original task.

    When I hover over the original task the popup shows “0” for subtasks.

    Additionally, when I try to use the cute little plus sign on the Tasks view to create a new subtask, I get a 404 Error stating: “No such page exists in GTM System or you don’t have enough rights to access it.”

    SOS! 🙂



    hi i have the same pb subtask not created
    but i found the bug and fix it
    its in the bp-gtm-system/templates/gtm/task_create.php
    replace the variable to the variable $parent_task to $parent_task_id

    if (is_numeric(parse_url($url, PHP_URL_QUERY)) && parse_url($url, PHP_URL_QUERY) > 0) {
        $parent_task_id=parse_url($url, PHP_URL_QUERY);//mod AMBA
        $parent_task = BP_GTM_Tasks::get_task_by_id($parent_task_id);
        $h4_title = __('Create New SubTask for', 'bp_gtm') . ' ' . bp_gtm_get_parent_task_link($parent_task, $gtm_link) . '';
    } else {
        $parent_task = 0;
        $parent_task_id = 0;//mod AMBA
        $h4_title = __('Create New Task', 'bp_gtm');

    and found the input to change variable :
    <input type="hidden" name="task_parent" value="<?php echo $parent_task_id; //mod AMBA ?>" />

    i works now for me
    hope its help you
    best regards



    this code resolve just the adding form subtask but not the show of subtask in a task. I work on it and return here to put a solution if i found it



    i found the other bug its in the ajax file :
    in fact bp-gtm-systems/_inc/globals.js
    a the begining of the file
    change var ajaxurl = '/wp-load.php';
    var ajaxurl = '/wp-admin/admin-ajax.php';

    and i works now show subtaks delete and other function using ajax
    best regards



    i have to change my last advice
    in fact don’t change the general setting
    var ajaxurl = '/wp-load.php';
    but just change
    url: ajaxurl,
    url: '/wp-admin/admin-ajax.php',
    line 57
    because changing the general ajaxurl bloc other script
    and i see that when the “cookie:” is pass to the ajax url
    functions doenst work then i comment all the “cookie” line
    hope its help

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: BP GTM System] Sub Tasks not working for me’ is closed to new replies.