Support » Plugin: BP GTM System » [Plugin: BP GTM System] GTM Plugin not working

  • Resolved marcuscake

    (@marcuscake)


    I have a working WordPress (3.3) and Buddypress (1.5.2) installation with up to do date plugins and a new Dynamix template recently upgraded for Buddypress and WordPress.

    When I install the GTM plugin, the following occurs:
    * the front sidebar on the home, post and pages moves down the page (ie; all pages are distorted)
    * the “Projects and task” option appears within each group – if I click on the group, a white page appears (it is not a 404 or 500 server error).

    The plugin does not appear to be working. If I can help fix (or get the plugin working), please let me know.

    http://wordpress.org/extend/plugins/bp-gtm-system/

Viewing 14 replies - 16 through 29 (of 29 total)
  • Plugin Author Slava Abakumov

    (@slaffik)

    krackers87,

    Go to plugin admin area. Check there the radio button – delete all data when uninstalling the plugin. Go to Plugin page, deactivate the plugin – all tables and settings will be removed.
    Then activate the plugin again. After that should be ok.

    Tried that before but did it again for good measure, didn’t really change much. Is it possible to get the steps you would take in detail, for setting up a fresh installation of WP with BP and GTM? Including any default options changed or things like making a second user account. This way I can try to replicate that to see if it may help.

    I too am having similar issues with GTM. I had a previous version of BP and GTM installed and when I upgraded both I had issues with managing projects and tasks, e.g. when I would click on the Delete or Complete icon it wouldn’t result in any action. Let me know if I can help with any testing. I’m anxious to get this going. By the way, regardless, it’s a great plugin. Thanks.

    The same here…

    I tried add more users to group but without difference. There is my error from log. Is there problem with new BP theme?

    mod_fcgid: stderr: PHP Fatal error: require_once(): Failed opening required '/public_html/wp-content/plugins/bp-gtm-system/templates//index.php' (include_path='.:/usr/share/php:/usr/share/pear') in /public_html/wp-includes/theme.php on line 1115, referer: http://localhost.home/project/spaceship-commander/admin/gtm

    I also think this is a fantastic plugin. Very important in the Buddypress and broader community. We can be grateful for such a quality plugin from Slaffik and also that he is releasing another version next week.

    Plugin Author Slava Abakumov

    (@slaffik)

    yobikwhatus, angelxube, marcuscake,

    Your problems are caused only because you’ve upgraded from 1.0.1 to 1.5+ – that’s the only reason I can replicate. In GTM 1.7 you should not have this issue.

    1.7 will be released in 3-12 hrs, I hope. Currently testing and doing some minor fixes and code improvements.

    And thank you all about your good words 🙂

    I didn’t update BP nor plugin. I just install new BP and latest plugin on fresh installation.

    I updated to 1.7 but it still does not work properly. When i click on Group, GTM ToDo a try add new project it fails – Page not found.

    This page:
    `…/groups/project/gtm/projects/create

    Also it doesn’t load any another page.

    Tasks
    Classifier
    Involved
    Discussions
    Settings
    Delete

    Only Projects but i can’t create one.

    Group>Settings>Todo – It load page but there is just no option or even text.

    Where could be problem?

    I realised problem with customizes BP slug. I changed /groups to /projects

    Perhaps for future version you can fix it or we should stay with default slug for groups?

    But still in settings of group there is no option to change. Is it right?

    Wow! The update really fixed a lot, thank you so much 😀

    I’m only having one issue now, same as angelxube. The create new project button tries to take me here:
    /groups/tester/gtm/projects/create
    When this is the right adress:
    /groups-2/tester/gtm/projects/create

    Not colossal tho since at least the url can be hacked to fix that bit.

    Edit: Most of the frontened buttons seem to take me to a similar incorrect url that can be hacked to fix.

    Edit 2: Fixed everything completely by restoring original slugs, realized the -2 at the end was because of reinstalling/uninstalling BP, but was an easy fix, and now everything seems to be working perfectly.

    Plugin Author Slava Abakumov

    (@slaffik)

    angelxube,
    Absolutely forget about customized slugs. Thanks! I will fix it in GTM v1.8.

    krackers87,
    Many thanks for your update. As I already said, I will make slugs flexible. Stay turned!

    ———

    I would be really thankful for your suggestions for future versions here.

    I am still getting the same error as I described above (distorted from page – just insertion of a gray background behind lists in a specific template shortcode). I am running WordPress 3.3.1 and GTM 1.7.1.

    I understand that there appears to be a fix above. Can someone explain how I implement it?

    Perhaps, it is better if I wait for GTM 1.8.

    SlaFFik, I can give you access to my blog if it provides another place to test. It would certainly help me.

    I notice your invitations for suggested new features. I have an idea for. I’ll publish shortly. In essence, it is about what comes before project management. The before is taking wants (from the activity stream) and determining needs (that become projects). The project management part would include logistics. The after would (maybe) measure outcomes. Just an idea … I’ll think about it some more and put it down in the forum.

    I think your problem is with template you are using. Try default BP template or modify structure by your own in GTM plugin directory. But with new update, you will have to change it again…

    So best you can do is using child-theme with just changed CSS.

    I also tried deleting the plugin (and files) and then I deleted the GTM database tables.

    I reinstalled the plugin. I clicked on the GTM Project Mgmt tab and I still get a white screen and it distorts my home page (by making the background of bullet points gray).

    In the admin screen: Unfortunately, there are no longer any default roles in GTM and it “Some error occurred while creating a default role” when I try to create them.

    I’ll wait for version 1.8.

    Plugin Author Slava Abakumov

    (@slaffik)

    Found and fixed blocking bug with child themes – plugin didn’t work with them. Currently it works.
    Enjoy!

Viewing 14 replies - 16 through 29 (of 29 total)
  • The topic ‘[Plugin: BP GTM System] GTM Plugin not working’ is closed to new replies.