WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: BP GTM System] GTM Plugin not working

[Resolved] [Plugin: BP GTM System] GTM Plugin not working

  • I have a working WordPress (3.3) and Buddypress (1.5.2) installation with up to do date plugins and a new Dynamix template recently upgraded for Buddypress and WordPress.

    When I install the GTM plugin, the following occurs:
    * the front sidebar on the home, post and pages moves down the page (ie; all pages are distorted)
    * the “Projects and task” option appears within each group – if I click on the group, a white page appears (it is not a 404 or 500 server error).

    The plugin does not appear to be working. If I can help fix (or get the plugin working), please let me know.

    http://wordpress.org/extend/plugins/bp-gtm-system/

Viewing 15 replies - 1 through 15 (of 29 total)
  • Plugin Author Slava Abakumov

    @slaffik

    Are you using GTM 1.6?

    Yes, I am using GTM 1.6.

    I disabled all plugins.I activated Buddypress and Buddpress GTM. All caches were turned off and emptied. I went to a groups page. It displayed GTM’s “Projects and tasks” groups tab.I clicked on it and it did the same thing – ie;it returned a blank empty white screen (not a 404 or 500 server error).

    I then switched to the “Buddypress Default 1.5.2″theme. When I click on GTM’s “Projects and tasks” tab, a list of recent posts appears (not the white page above). At this stage only two plugins are active(Buddypress and Buddypress GTM plugins)and the Buddypress Default theme. GTM still does not work.

    My WordPress installation runs well with more than 60 plugins. GTM distorts the layout of pages and posts (by shifting page/post content down until it is past the content in the right sidebar) and delivers a white page when clicking on the “Projects and tasks” tab on the Dynamix theme, or recent posts on the Buddypress Default theme.

    I think the problem appears to be with the Dynamix theme, and GTM. I am very keen to use the Buddypress GTM plugin. I have tried Collabpress which appears to be more popular, but has a fraction of the functionality and is not intuitive. Collabpress also distorts the “Accordian” text bullet point feature used on the home page.

    I will post this in the GTM plugin forum and the Dynamix forum. I would be very grateful for any help.

    FYI – The plugin will be used at http://www.marcuscake.com/community/groups/economic-development/ and other groups.

    I seem to be having a similar problem and I’m using the same versions as marcuscake. Also i get an error when clicking on the Assignments, Tasks and Projects tabs under My Account from the my dropdown admin bar menu.

    Warning: require_once(****/wp-content/plugins/bp-gtm-system/templates//personal/home.php) [function.require-once]: failed to open stream: No such file or directory in ****/wp-includes/theme.php on line 1115

    Fatal error: require_once() [function.require]: Failed opening required ‘/****/wp-content/plugins/bp-gtm-system/templates//personal/home.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /****/wp-includes/theme.php on line 1115

    the **** is blanked out to save space, and is just the file directory of the server up to the main wordpress folder.

    Finally in the settings tab, clicking actions next to a user role seems to do nothing, and new default user role gives the error: “Some error occured while creating a default role”

    Actually, i think I fixed it. It seems to really not like only one user being in a group. My apologies for that.

    Hi Krackers87

    That’s not the cause of my problem. I have more than one user in the groups that I have been trying to run GTM.

    Is there anything else it could have been. I could try it on my site.

    Ok, here’s what I did. Fresh install with Buddypress and WP, then i isntalled the group forums, but not the sitewide forums. From there I still had the no ToDo tasks problem with a created group with just the one user account. Next I made a second account and had it join the group, whereupon I was then able to create Projects and Tasks as the fields for them began to show up with two users in the group. However, at this point I still am experiencing problems with changing a user’s roles specific to GTM, both through the group menu and through the settings tab under the dashboard.
    When attempted on the group page under ToDo tab, I get a white rectangle that is otherwise blank, that comes up as a lightbox. When I try to manage roles in the dashboard menu, I just get no response from the buttons whatsoever.

    I also noticed that certain other parts of Buddypress, unrelated to GTM, would not work until I did a certain action, like status updates, friendship requests, comments on groups and friendship requests did not work until i made a comment with one of the accounts on a post. I feel this may be somewhat related.

    Correction, it seems GTM is breaking things like joining/leaving groups, activity feeds and so forth, I could of sworn it worked earlier, but maybe being tired is affecting my memory.
    I feel like im having such a hard time getting anywhere here.. >.<

    Plugin Author Slava Abakumov

    @slaffik

    marcuscake,
    Go to plugin admin area (in wp-admin) and click Save button.
    GTM Template should be used. In 1.5 and above you can create own templates (currently in plugin folder, soon will be moved to theme folder). When upgrading from 1.0 there is no default value for the GTM template saved in settings – so you need to save it.
    Please try and say whether it helped or not.

    Sorry for that.

    Plugin Author Slava Abakumov

    @slaffik

    krackers87,
    It’s not breaking that things – I’ve tested it.
    What theme are you using?

    I’m using the Buddy Press Default 1.5.2

    Plugin Author Slava Abakumov

    @slaffik

    krackers87,

    It seems to really not like only one user being in a group.

    Will be fixed in next release this week.

    Can you completely reinstall the BuddyPress with no plugins activated? Then please activate them one by one from top to bottom on plugins page. After each activation check whether you have problems or not. In such way you will find what plugin conflicts with another.
    After that you should deactivate one by one plugins that were activated on a previous step – so you will define the plugin which conflicts with the latest activated.
    Please do it and write the results.

    Thank you.

    I have reviewed the WP-admin area. I can not find any option to change a template for GTM. There is no option on the GTM Plugin page in wp-admin to change a template.

    Even though I couldn’t find the field to specify a template, I have clicked on the save button in the wp-admin section. The result was the same as described above. No change!

    I am pleased to hear there will be a new version next week. I consider this a very important plugin for the Buddypress and broader community. Thank you!

    Plugin Author Slava Abakumov

    @slaffik

    marcuscake,

    Even though I couldn’t find the field to specify a template

    This field is hidden via php code. It will be revealed in next version (in a day or two).

    I was running Buddypress and GTM only, there are no other plugins i had installed, besides akismet and hello dolly (the bundled WP plugs) and those were never turned on.

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘[Resolved] [Plugin: BP GTM System] GTM Plugin not working’ is closed to new replies.