WordPress.org

Forums

BP GTM System
Delete/mark complete no working/updated in Project/task (10 posts)

  1. bodjiang
    Member
    Posted 2 years ago #

    Hi,

    I running a new fresh installation on latest wordpress 3.4.1, buddypress 1.6.1, and the GTM 1.9.5, I'm running default BP themes.

    I had 2 role setting for testing, Owner and project manager, where I can create the task and project, edit them, and comment them for no problem, but I can't have it mark as complete, or delete the task/project under any of this role.

    is there known fix I missed?

    http://wordpress.org/extend/plugins/bp-gtm-system/

  2. blackshore
    Member
    Posted 2 years ago #

    I have the same problem.
    My site: http://tortugaisland.se

  3. clayborn
    Member
    Posted 2 years ago #

    same thing : buddy press update breaks the complete/delete buttons for projects and tasks;the javascript works but when you check again the project/task has not been deleted/marked as complete

  4. fordp
    Member
    Posted 2 years ago #

    Same problem for me.

    Also, another issue.. Since I am using this as part of an internal system, my WordPress install is at: mysite.com/collaboration/

    Inside of global.js, line 3, I had to change:

    var ajaxurl = '/wp-load.php';
    to
    var ajaxurl = '/collaboration/wp-load.php';

  5. clayborn
    Member
    Posted 2 years ago #

    yep I 've been fixing the javascript so it would work altogether but it seems broken because of the buddypress 1.6.1 update - does any of you guys have an idea of what could break it ? I must admit I dunno where to look.

  6. fordp
    Member
    Posted 2 years ago #

    We are starting to use our system internally tomorrow, so I should have a fix to share one way or another in the next 24hrs

  7. clayborn
    Member
    Posted 2 years ago #

    ooooh very interesting
    you may have noticed the problem occurs as well in the file tab with its delete function.
    I will have to look deeper into it myself but I must admit you've brought very good news.
    Thank you for that.

  8. clayborn
    Member
    Posted 2 years ago #

    I couldn't find the fix , could you ?

  9. clayborn
    Member
    Posted 2 years ago #

    it's a query cookie problem that shows up and I'm not able to fix it by myself; it displays as an error since the 3.4.2 update.I'll remove the delete and edit buttons from the whole component as no solution seems to be online.

  10. fordp
    Member
    Posted 2 years ago #

    Whooa sorry. Forgot to check back here - I'm going to update my name/email here so I get updates :)

    What I did, was change the ajaxurl to:

    var ajaxurl = '/collaboration/wp-admin/admin-ajax.php';

    inside of bp-gtm-system > _inc > global.js - third line

    Works for my setup

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • BP GTM System
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.