Support » Plugin: Partner Program Plugin » [Plugin: Partner Program Plugin] Insert doesnt work

  • Resolved timmeh83


    Dear reader,

    i was happy to find the update that makes a sub-folder installation possible.
    Unfortunately it still doesnt work as it should.
    I don’t get any errors and i am able to create a link, except that the ‘insert’ (invoegen) button doesnt work after the link is set up as i want.

    The button seems to respond somehow, because if i forget to enter a name, it will give me an error saying that i forgot to fill up the name.

    I hope you can help me with this.

    Kind regards,

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author Netvlies


    There was a problem with the rendering directly in the page content which is solved with version 1.0.5.

    The error described was also encountered during the testing of 1.0.5 but I wasn’t able to reproduce the issue after I refreshed the browser. So that might help. From the content editor, the plugin should remove the popup and insert the code in the content. From the widget page, the popup stays open and informes that the settings have been saved.

    I Hope this helps, because I wasn’t able to reproduce the error.

    Thanks for your update regarding my problem.
    Unfortunately i still have the same problem. I refreshed the browser (Google Chrome) after the update to 1.0.5 , and also gave it a try in IE 9.

    For your information, i am running wordpress 3.4.1.
    The installation is in the

    I hope you can help to solve my problem.

    Kind regards,

    update: Just updated wordpress to 3.4.2 and still have the same problem

    First time user of your plugin.
    I can confirm the same error, insert (invoegen) doesn’t work for me.
    Tested on Firefox and Chrome.

    Error in clientProductlink.js line 46:
    Uncaught ReferenceError: bol_pml is not defined

    Edit: WordPress version 3.4.2

    Plugin Author Netvlies


    @janbr: Thank you for the detailed report. It seems like you have both the old and the new plugin activated in wordpress. The javascript file ‘cliendProductlink.js’ is from the plugin by the previous developer. We had to build the plugin from scratch, so the code is definitely not backwards compatible. If the old plugin is present, please disable or preferably remove the plugin.

    I hope this information solves the problem.

    This is the first time I use your plugin and haven’t tried/installed an old BOL plugin. Still I can’t use the insert (invoegen) button.

    Now in the meantime I use a Custom Field hoping that you can find the error.

    Jan, can you tell me how you found out what error you got? I dont’s get any error at all.

    I use the Developers Tools for browsers on my localhost. It also shows errors. Like: Uncaught ReferenceError: bol_pml is not defined clientProductlink.js:46

    If I click on the link clientProductlink.js I get directed to:

    I installed the plugin today on an external server and the button “invoegen” doesn’t work there either. Only on the external server the Developers Tools gives no errors.

    I use Ubuntu on the localhost and the external server also works on Ubuntu.

    Same problem…insert does not work. Tried upgrading versions etc but still the screen with ‘Configureer Widget’ stays while showing the preview. Also changed plugin directory to /bol/ as stated in other forums. Used a complete clean version to try it.

    WordPress 3.4.2

    Plugin Author Netvlies


    I performed a fresh wp install with plugin 1.0.5 install today in a subdirectory. I was able to reproduce the issue reported by timmeh83 today .

    There will be a new version of the plugin today, with several improvements. I will add the fix in with the new version.

    Thank you for your response. Yesterday i also finally found a solution that seems to work for now.
    I’v edited the file, because it didn’t load the tinymce popup properly.

    Looking forward to your fix as well. So i know everything runs as it should

    I have updated the plugin to version 1.1.1

    I use WP 3.4.2 both on my localhost as on a remote host. It works great on my localhost now but not on the remote host. I deactivated all plugins but still I can’t get the “invoegen” button to work.

    How can I help to get this to work.

    With this update installed it works for me now! Thx!

    WP 3.4.2

    For me it still isn’t resolved.

    Using WP 3.4.2

    For instance this shows on my “Bestsellerlijst”. The button “Invoegen” shows “{#insert}” and the button “Annuleren” shows “{#cancel}”

    Invoegen doesn’t work. I would like to debug to find the problem but I don’t know if you can debug WP.

    Hello Jan,

    i managed to solve this problem bij editing this file:

    In line 26 i had to change the path, so it could load tinymce properly.

    Please let me know if this solved your problem

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Plugin: Partner Program Plugin] Insert doesnt work’ is closed to new replies.