Support » Plugins » [Plugin: Boilerplate]Insert dialog box missing something?

  • I’ve installed the plugin and it works fine when I insert the shortcode manually in a post. That saves much time!

    It would be good to have the editor working as it should though.

    In the Visual Editor I see the icon. When I click on it I get a dialog box with a drop down box, in which is the one boilerplate I created. I can select it, but then nothing. No save button. Just the x top right to close the dialog. Nothing appears back in the post when I close the dialog.

    Have I missed something? I tried reloading all the code just in case, but no joy. Any ideas?


Viewing 9 replies - 1 through 9 (of 9 total)
  • When you select the post it should automagically close and insert the shortcode. Not sure why this would not work. I’ll take a look at the code and see if I can spot anything, but so far it seems peculiar to your system.
    Please see if it works when the other plugins are disabled, to see if they are affecting it.

    Thanks for that. I disabled all the plugins bar Boilerplate but still the same – dialog shows, I can highlight a panel but on closing no code is inserted into the Post.

    I am running PHP 5.2.7 BTW.

    More info – the dialog box disappears on mousedown, not mouseup.

    I’ve tried the same insertion using Firefox, IE and Safari. Nothing returned in Firefox or IE. In Safari the Boilerplate icon for the editor doesn’t appear at all. Javascript is enabled in all three.

    … and the answer is: you are not allowed to select the first panel in the list. You need at least two panels configured and even then the dialog will not return the first one displayed. Every other panel when selcted automatically closes the dialog.

    you are not allowed to select the first panel in the list.

    The first item ie. Select… is just an instruction and is therefore greyed out and unselectable.

    Even with just one actual plate in the list it works as expected.

    Are you trying to select the Select… or do you have a problem just selecting the first actual plate? As this seems to work as expect on the test system.

    No, not the greyed out Select … actually when you first click on the Boilerplate icon in the editor, the dialog box appears and the item presented (pre-selected) in the box is the unusable plate. Click on the drop down aroow and you get the full list starting with the unselectable Select …, followed by the unusable plate, follwed by the usable plates.

    I started by creating 1 plate (plate a). The dialog then lists it ok, I could move the cursor to it ok, but the dialog stayed open. Using the x to close the dialog meant nothing got returned.

    Then I created another plate (plate b). Both plates are listed in the dialog ok. If I then select plate a the panel doesn’t close. If I select plate b, plate b is returned to the post ie it then works correctly.

    It seems that whatever plate is listed first in the dialog it can never be selected. All the others can.

    Hope this helps. I can’t see anything strange in your form code for the dialog but it is definitely behaving strangely.

    I’ve been testing it on chrome and safari on a mac and it all works as expected.
    Just tried it on firefox and I can see it.

    It seems to be that since Select… is greyed out it moves the selected item to the first in the list. Where as the browser I have been using don’t. Since the selected value doesn’t change when selecting the first option it will not fire up the save action.

    There will be a fix in the next release.
    Thanks for your input.


    Well done!

    I was using Firefox, Safari and IE on a Win7 PC for my sins. Glad you found it – look forward to the update.

    I can understand why it does it. Don’t know why safari on windows renders differently than on the mac.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: Boilerplate]Insert dialog box missing something?’ is closed to new replies.