Support » Plugin: Boilerplate » [Plugin: Boilerplate] Search/Replace failing (WP 3.4 )

  • None of these work. I have CITYX in my plate, but that’s what shows up on the derived page no matter what. I’ve tried:

    [boilerplate lorem-boilerplate CITYX = "New City"]
    [boilerplate lorem-boilerplate CITYX = "NewCity"]
    [boilerplate plate = "Lorem Boilerplate" CITYX = "New City"]
    [boilerplate plate = "lorem Boilerplate" CITYX = "NewCity"]

    No matter what, my page displays with CITYX instead of the replacement. WP 3.4 perhaps?

    Also are there samples somewhere? Or official docs on usequery or other attributes? Also the docs don’t mention the plate id version of the shortcode, but it’s listed in the list of plates. Updates?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author DCoda


    There are no samples as it would be very difficult to demonstrate them working.
    Is a brief guide to getting started, but I assume you have read this. There is no advanced guide and there isn’t that much to the plugin.

    I’m confused as to what docs you have been using as the only docs are listed about and they do mention the plate attribute.

    My Real Question
    Okay. That’s fine. But should my codes (above) be doing the right thing? Have you tested this in WP 3.4 and WP 3.4.1?

    Side Note on Documentation
    The ONLY example on that page:

    [BoilerPlate plate = "title" search = "replace"]

    In the admin list of plates when I use it in WP it says the shortcode looks like:

    [boilerplate lorem-boilerplate]

    That version (using the plate ID instead of plate=”Lorem Boilerplate” as an attribute) is not documented. I was just making a note for your reference.

    The note in your docs on how to use “search” is not clear. I thought it’d be great for you to have a single example to follow.

    For instance you could add this to the docs:

    To replace “FOO” in boilerplate “test” with “bar” use:

    [BoilerPlate plate = "test" FOO="bar"]

    Plugin Author DCoda


    As stated on the plugin site it is only tested up to 3.3.2.
    But I doubt it would be the version that is causing the problem. The plugin uses basic wordpress filters that are unlikely to have change that drastically.

    Your examples do seem syntactically correct. try using lower case and try disabling other plugins that may be affecting the filter.

    The documentation does basically say what you want but uses the words search and replace instead of foo and bar.

    Okay. “search” and “replace” seem like KEYWORDS. Bad semantics.

    I’ll play with it and see if I can get it to go. I’ll let you know what I find.

    Yes, any capital letter in the placeholder breaks the replace function.

    It would be useful if this worked with capital letters so your placeholders could stand out like __PLACEHOLDER__

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Boilerplate] Search/Replace failing (WP 3.4 )’ is closed to new replies.