Support » Plugins and Hacks » [Plugin: Blogger Importer] Invalid Token

[Plugin: Blogger Importer] Invalid Token

Viewing 15 replies - 1 through 15 (of 49 total)
  • Plugin Author Workshopshed


    Are you already logged into Google before pressing the button?
    What happens if you go to Blogger.com directly do you get a list of your blogs?

    Are you running from a test domain / local install? That’s one combination I not sure is tested?

    Plugin Author Workshopshed


    I managed to get the same message by switching browsers and using an account I’d never used before. The interesting thing was that when I went back into the importer it had authorised and showed my blogs. Now I can’t reproduce the problem.

    I was also thinking it might be some kind of timeout issue but I’ve tried waiting a couple of minutes between steps and that did not cause a problem.

    Yes I was logged in to google before trying the importer (with the account I wanted to import from). Also I do see the blog at blogger.com in my account that I would like to import.

    I tried logging out of my account then tried to import from blogger again and still get the invalid token. When I go back to my WordPress install I do not see my blog listed, only the ‘authorize’ button.

    Nothing is showing up in the php error logs and google doesn’t give me anything very descriptive except ‘Invalid Token’.

    Here is the actual url I’m redirected to (I’ve remove the blog url but everything else is as is). Notice that there doesn’t seem to be any values for token or token_secret:


    Also shouldn’t the ‘%3D%26’ actually be ‘=&’ ?

    I see it’s just the url encode of the oauth_callback parameter. Guess I’m out of ideas as to what the issue is.

    Plugin Author Workshopshed


    Is your blog locally hosted?
    Do you login to the Admin dashboard on HTTPS?

    The blog is not locally hosted and I do not access the admin via https.

    Plugin Author Workshopshed


    I’m afraid the OAuth stuff is a bit beyond my skill set, I mostly looked at the processing of the feeds from XML. Perhaps Otto might be able to help?

    I’m facing the same problem…

    I’ve been having the same problem. It just won’t work. The “Invalid Token” message pops up after I click Authorize and I just can’t make it work. Please fix this ASAP as the issue prevents the plugin from being used.

    I have the same problem. Please, fix this!

    Plugin Author Workshopshed


    As you might appreciate it’s not understood why you get this issue and if it is specific to your wordpress install or blogger account in some way.

    You can check if it’s something about your account by visiting googles OAuth playground.


    1. click blogger
    2. skip this box
    3. click request token
    4. click authorise (this should take you to the google authorise screen)
    5. Upgrade token
    6. Paste “https://www.blogger.com/feeds/default/blogs” into box 6 and press execute

    If you get this far without errors then it’s nothing specific to your account or blogger blogs that’s causing the importer to error.

    Once you’ve checked with Google’s OAuth Playground you should press the “start over” button to clear things down.

    Plugin Author Workshopshed


    Looking at the plugin authorisation code, there is another really simple check you can do.

    If you view the source code of the greetings page with the “Authorise” button on it. You should see a small form like the following:

    <form method="get" action="https://www.google.com/accounts/OAuthAuthorizeToken">
    <p class="submit" style="text-align:left;">
    <input class="button" type="submit" value="Authorize">
    <input type="hidden" value="4/VzMd0q8590WuynODngibGiSm5Yfh" name="oauth_token">
    <input type="hidden" value="http://mytestblog.com/wp-admin/index.php?import=blogger&noheader=true&token=4/VzMd0q8590WuynODngibGiSm5Yfh&token_secret=FJ5oONrlFqyDUx3JPGwl8ir1" name="oauth_callback">

    Confirm that there are values for the oauth_token and there is a value to the right of &token_secret.

    Hi, I am experiencing the same issue, I’ve edited the importer code to show the error message (as written in this ticket), and I get a “name lookup timed out” error.
    I tried checking my account using OAuth playground and it all seems working.

    Interestingly, I’ve registered a free account at wordpress.com (I wanted to try and see if I had the same issue there), but it works flawlessly there.

    Plugin Author Workshopshed


    Velerio, nice to know that diagnostics function was of use. Googling that message, it’s occurred for a few people in different places, specifically downloading of updates.

    This article seems to have a work around that should work in this case.


    For another plugin I added the action ‘wp_feed_options’ to change the timeouts, we might be able to use the same technique here.

    Works like a charm! It’s importing!
    I really owe you one 🙂
    Thank you so much!
    I also hope this can be useful to other people having this same issue.

    So, do you think this problem could originate from crappy hosting? I’ve been trying a different hosting company because I had issues with my previous one (not related to this particular case), and I want to make sure whether it’s the cause of the problem or not.

Viewing 15 replies - 1 through 15 (of 49 total)
  • The topic ‘[Plugin: Blogger Importer] Invalid Token’ is closed to new replies.