Support » Plugin: All In One WP Security & Firewall » Plugin blocking payment gateway

  • Resolved drbrahm

    (@drbrahm)


    I use “PagSeguro” as payment gateway but when the plugin is active I do not receive payment gateway notifications.

    I have tried some instructions from this topic:
    https://wordpress.org/support/topic/wp-security-blocking-paypal/

    but they did not work.

    how could I whitelist/allow the payment gateway notifications work? The notifications are send by post to my site.

    • This topic was modified 3 years, 9 months ago by drbrahm. Reason: forgot to include important information
Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, what part of the instructions did you try in the forum post link you shared above?

    Thank you

    Thread Starter drbrahm

    (@drbrahm)

    I did all changings mentioned on that topic but they did not work.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, did you disable all Firewall rules? Then carried out a test?

    Plugin Contributor wpsolutions

    (@wpsolutions)

    Hi @drbrahm
    Before you start to modify certain firewall rules, I always recommend that you perform some simple methodical tests first.

    For example:
    If you have multiple firewall rules enabled then try the following:

    1) Disable one rule and do a test to see if that gateway is being blocked. If problem goes away take note of the rule you just disabled and leave it inactive.

    2) Repeat above step one test at a time until you find the rule causing the blockage.

    • This reply was modified 3 years, 9 months ago by wpsolutions.
    Thread Starter drbrahm

    (@drbrahm)

    hi guys,

    thanks for the replies.

    When the plugin is disabled the payment gateway notifications are received correctly.

    In PagSeguro (payment gateway) I got this information about the notification post:

    POST http://lojamodelo.com.br/notificacao HTTP/1.1
    Host:pagseguro.uol.com.br
    Content-Length:85
    Content-Type:application/x-www-form-urlencoded
    notificationCode=766B9C-AD4B044B04DA-77742F5FA653-E1AB24
    notificationType=transaction

    (https://pagseguro.uol.com.br/v2/guia-de-integracao/api-de-notificacoes.html#v2-item-servico-de-notificacoes)

    In meantime I will try to disable rule by rule in plugin to check wich one is blocking the payment gateway notification

    • This reply was modified 3 years, 9 months ago by drbrahm. Reason: extra information provided
    Thread Starter drbrahm

    (@drbrahm)

    Hi,

    After some testings unchecking the option [] Firewall 5G (legacy) the payment notifications start working again.

    is it safe make this option unchecked? would you recommend another workaround?

    Please let me know.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi @drbrahm, that might explain your issue. Please enable the following option below instead. Enable 5G Firewall Protection is out of date and old.

    Enable 6G Firewall Protection

    Give the above a try and report back. If you still have issues then disable the above option as well.

    Also do you have the latest plugin version 4.3.2.

    Regards

    • This reply was modified 3 years, 9 months ago by mbrsolution.
    • This reply was modified 3 years, 9 months ago by mbrsolution.
    Thread Starter drbrahm

    (@drbrahm)

    hi,

    I have checked [X] 6G firewall and it is still working my payment notifications.

    Yes, I am using an up to date version of the plugin.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, I am glad your issue is resolved.

    In the future the developers will remove the 5G rules. This feature is old. 6G rules is much better 🙂

    Enjoy the plugin.

    Kind regards

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Plugin blocking payment gateway’ is closed to new replies.