• Resolved George

    (@quantum_leap)


    I am including a plugin only on a custom post type. The issue here is that this plugin has a block that can be inserted in the block editor. It’s a gallery plugin and once a few images are selected, it displays a gallery preview right in the block editor. I don’t see that preview anymore.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Jeff Sterup

    (@foomagoo)

    If you have the plugin disabled on the admin pages it won’t display in the block editor.

    Thread Starter George

    (@quantum_leap)

    I haven’t touched the admin pages at all.

    Plugin Author Jeff Sterup

    (@foomagoo)

    You said you’re including a plugin only on a custom post type. I assume that means you’ve disabled it globally and then enabled it on that post type through the post type plugins admin page. If you have the setting turned on to enable admin plugin disabling that would disable the plugin on admin pages.

    Thread Starter George

    (@quantum_leap)

    You said you’re including a plugin only on a custom post type. I assume that means you’ve disabled it globally and then enabled it on that post type through the post type plugins admin page.
    Correct

    If you have the setting turned on to enable admin plugin disabling that would disable the plugin on admin pages.
    I do not have Selective Admin Plugin Loading activated.

    Plugin Author Jeff Sterup

    (@foomagoo)

    Are you using a site building plugin or theme like divi that lets you build the site on the front end? Do you see any JavaScript errors in your browser console?

    Thread Starter George

    (@quantum_leap)

    No, I am using the GeneratePress theme with the GenerateBlocks plugin (block-based). The portfolio plugin in question is this. It uses a block that renders a front end preview in the block editor.

    No related errors in the console. It kind of renders something which seems to be the admin top bar!

    Plugin Author Jeff Sterup

    (@foomagoo)

    That’s why it isn’t working. It’s rendering on the front end and you have the plugin disabled there.

    Thread Starter George

    (@quantum_leap)

    The reverse seems to be working. Enabling the plugin everywhere and use filter to exclude it on certain URLs since it only loads assets on those URLs and not on the whole site for some reason. Those filters came to be really useful in my case.

    Anyway, thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.