WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Black Studio TinyMCE Widget] Text in 'visual' display mode goes off right side of

[Resolved] [Plugin: Black Studio TinyMCE Widget] Text in 'visual' display mode goes off right side of

  • brianmulawka
    Member

    @brianmulawka

    The plugin works, except that when I am editing text in the widget in ‘visual’ display mode it wraps past the editor box and off teh right side of the window where I then can’t see about 25 characters. This happens in Firefox 11.0. When I open the page in IE9 I get the same issue, except when I keep typing off the page the box follows the cursor, so the left side of the box is not visible.

    I went in to the editor and changed the width of the plugin from 600px to 400px and the box gets smaller but behaves the same way.

    http://wordpress.org/extend/plugins/black-studio-tinymce-widget/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Marco Chiesi
    Participant

    @marcochiesi

    Thanks for your report. Reading the description of the issue, I believe this can be caused by a CSS conflicting rule coming from the theme (or another plugin). Please could you try to temporarily switch to another theme (TwentyEleven) and check if it works or not? Which theme are you using?

    brianmulawka
    Member

    @brianmulawka

    I switched back to TwentyEleven and the same thing happened.

    I am using the Catalyst theme.

    Any other suggestions?

    Plugin Author Marco Chiesi
    Participant

    @marcochiesi

    Please could you list the other plugins you are using?

    Morgan Kay
    Participant

    @gwendydd

    For what it’s worth, I have had this same problem with several different themes. I always write themes using Starkers HTML5 as the basis (which is in turn based on twentyten), and this plugin always behaves like this.

    Josh
    Participant

    @josh401

    I went in to the editor and changed the width of the plugin from 600px to 400px and the box gets smaller but behaves the same way.

    Perhaps you need to make it wider, instead of narrower? Try changing the setting from 600px to 700px and see what happens.

    brianmulawka
    Member

    @brianmulawka

    Perhaps you need to make it wider, instead of narrower? Try changing the setting from 600px to 700px and see what happens.

    DING DING DING!!!!

    Not only did this work, it made me feel incredibly dense for not thinking to even try this on my own. Either way, it works now and I really appreciate the help.

    For anyone looking for a different, maybe more elegant repair, it appears to be an issue with Tiny MCE forcing the width of the box to the length of the editor bar.

    Morgan Kay
    Participant

    @gwendydd

    I didn’t want to edit the plugin’s CSS file, so I added this to functions.php:

    // FIX THE WIDTH OF BLACK STUDIO TINYMCE VISUAL EDITOR
    function fix_blackstudio() {
       echo '<style type="text/css">
               .widget iframe { width: 600px !important; }
             </style>';
    }
    
    add_action('admin_head', 'fix_blackstudio');
    Plugin Author Marco Chiesi
    Participant

    @marcochiesi

    In latest release (0.9.1) I increased the width of the editor (to 720px) so there should be no more need to fix it via css.
    Cheers.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] [Plugin: Black Studio TinyMCE Widget] Text in 'visual' display mode goes off right side of’ is closed to new replies.