Support » Plugin: Black Studio TinyMCE Widget » [Plugin: Black Studio TinyMCE Widget] Not compatible with WPML?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Marco Chiesi

    (@marcochiesi)

    Hello ninusik,
    the current version of Black Studio TinyMCE widget plugin works together with the WPML String translation plugin.
    To translate a widget created with Black Studio plugin you have to create it on the widgets page and then go to WPML -> String translation and translate the title and text from there (unfortunately the translation textarea has no wysywyg editor).
    If you installed WPML after the creation of the widgets, just re-save them and they will appear on the String Translation list.
    A different approach to handle multi-language widget, while keeping the wysywyg editor, is to create a different widget for every language, and show each of them in correspondance of a particular language using relevant conditions. This can be achieved with additional plugins like Widget Logic or Dynamic Widgets.
    In next releases of our Black Studio TinyMCE widget plugin, we plan to improve the multi-language capabilities and let it be more similar to the Multilanguage text widget provided by WPML (which is not wysiwyg), with a dropdown menu for language selection.

    Hi Marco,
    Thank you so much. I didn’t realize that I needed to re-save previously installed widget in order for it to appear in String Translations. Thanks, it worked!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: Black Studio TinyMCE Widget] Not compatible with WPML?’ is closed to new replies.