WordPress.org

Support

Support » Plugins and Hacks » Black Studio TinyMCE Widget » [Resolved] [Plugin: Black Studio TinyMCE Widget] New TinyMCE Widget plugin

[Resolved] [Plugin: Black Studio TinyMCE Widget] New TinyMCE Widget plugin

  • Plugin Author Marco Chiesi

    @marcochiesi

    Hello,
    we just released our TinyMCE Widget plugin, that adds a WYSIWYG widget based on the standard TinyMCE WordPress visual editor. It is intended to overcome the limitations of the default WordPress text widget, so that you can visually add rich text contents to your sidebars.
    Please give it a try and send us some feedback, if you want.

    P.S. This is an alternative to the current version of “Wysiwyg Widgets” plugin, which is not working well at the moment.

Viewing 15 replies - 1 through 15 (of 17 total)
  • the_webscaper

    @the_webscaper

    Hi Marco!

    Was so happy to see a replacement for WYSIWYG Widgets… I’m in the 11th hour of a client project and while WYSIWYG is working for me, it is not for my client, so I need a fix ASAP.

    However, I’m having a problem. I installed your plugin and drop the widget into a sidebar, but am not getting the tiny mce buttons. I DO get the media insert buttons, but not the styling buttons.

    I thought maybe it was because I still had WYSIWYG installed, so I disabled and deleted that, then reinstalled yours – but still no buttons.

    Any thoughts? Did I mention I’m desperate? 😉

    Plugin Author Marco Chiesi

    @marcochiesi

    Hi webscaper,
    I will look into this, but I already have an idea about why it may not work correctly.
    Please could you check the following?

    • Do you see the “Visual” and “HTML” buttons on the top right of the widget? If you try to switch to HTML and then back to Visual, do the styling buttons appear? If the answer is “yes” I think I’ll be able to make a fix.
    • Which version of WP are you running?
    • Have you installed other plugins which may interfere with TinyMCE editor?
    • Could you check if your browser report some javascript error in the console?
    Plugin Author Marco Chiesi

    @marcochiesi

    I just released version 0.6.1, which should address the issue I was talking about.
    Please check it and tell me if it’s working for you now, otherwise please answer the other questions on my previous message.

    the_webscaper

    @the_webscaper

    Hi Marco –
    I got a reply from you on this post in my email but am not seeing it here… not sure what’s up with that.

    I installed your update, unfortunately, still no styling buttons 🙁 I also tried switching from HTML to Visual and back, but no success.

    I’m running WP 3.2.1, a few plugins but none that I can see conflicting (other than WYSIWYG Widgets, which I’ve un-installed). I do have Advanced Text Widget installed, but not activated. Other plugins… Advanced Excerpt, AJAX Contact, Calendar, Category Posts Widget, NextGen Gallery, Promotion Slider, WishList Member, WP Show IDs….

    I’m running Chrome, but have tried FireFox and IE9 and having the same issues there.

    Happy to provide any other info you need… I appreciate the help.

    Plugin Author Marco Chiesi

    @marcochiesi

    Hello the_webscaper, I don’t know what happened with forum messages. I see them all correctly here.
    Regarding the widget issue, unfortunately I cannot reproduce the problem you’re experiencing.
    In the meantime I released a new version (0.6.3) that may solve this problem too. Please give it a try.
    If it still doesn’t work, please could you check if there are JS errors reported in the Chrome console (just press CTRL+SHIFT+I, select “Console” tab and then load the WordPress widgets page).

    the_webscaper

    @the_webscaper

    Hi Marco,
    The update didn’t work unfortunately. I loaded the Chrome console as you asked. The only error is “Uncaught Error: chrome.tabs can only be used in extension processes. See the content scripts documentation for more details.” Seems to be related to one of my installed extensions so that isn’t the problem.

    The remaining info displayed shows no errors, but for what it’s worth I’ve pasted it all below. I can’t think of what else could be interfering, unless something built into this theme – but even then, I can’t imagine what…

    Uncaught Error: chrome.tabs can only be used in extension processes. See the content scripts documentation for more details.
    privilegedchrome/RendererExtensionBindings:288
    (anonymous function)chrome-extension://aonjhmdcgbgikgjapjckfkefpphjpgma/measureIt.js:120
    Mon, 14 Nov 2011 04:56:35 GMT
    1 : ID=26762 *SCRIPT* rf_CS_onLoad. Script loaded! url=http://www.thevineyardscommunity.net/wp-admin/widgets.php
    Mon, 14 Nov 2011 04:56:35 GMT
    6 : ID=26762 *SCRIPT* rf_sendMessageToBG. CS -> BGO : cmd:clearCS
    g_docnum:10402968
    Mon, 14 Nov 2011 04:56:35 GMT
    69 : ID=26762 *SCRIPT* rf_CS_receiveBG. COMMAND=setdocnum
    Mon, 14 Nov 2011 04:56:35 GMT
    69 : ID=26762 *SCRIPT* rf_CS_receiveBG g_docnum=0
    Also eval language localization data
    Mon, 14 Nov 2011 04:56:35 GMT
    70 : ID=26762 *SCRIPT* rf_CS_receiveBG. COMMAND=login
    Mon, 14 Nov 2011 04:56:35 GMT
    71 : ID=26762 #### LOGIN REMOVE-ADD EVENT Mouse_down and KEY_DOWN######################

    Thanks so much for your attempts to help… I realize without being able to reproduce there’s not much you can do, but I really would like to be able to use your plugin. Open to any suggestions.

    the_webscaper

    @the_webscaper

    Just FYI, I just installed your plugin on another site I have in development, and it works BEAUTIFULLY. I love it… now, just to figure out what is interfering on THIS site so I can use it! 🙂

    the_webscaper

    @the_webscaper

    Additional update: I set up a test site on my development server with a fresh installation of WP and the theme I am using on the site that your plugin won’t work on. However on the fresh install, your plugin IS working.

    That would lead me to suspect that one of the plugins on my client’s site is causing the problem. I’m going to install each of them on this sandbox site and see if I can determine the problem. I’m wary of just disabling them on my client’s site for fear I may lose some data (has happened to me before when disabling plugins).

    Fingers crossed and will keep you updated. I’m hoping that this information will also help you!

    the_webscaper

    @the_webscaper

    FOUND IT!

    It’s that stupid JetPack plugin! I had only installed JetPack because the annoying nag screen at the top of my page was getting my goat, and I just hadn’t gotten around to deleting it (I don’t really see what the value of that plugin is…)

    But sure enough – on the development server, I installed all the same plugins and one by one disabled, and JetPack was the culprit. Returned to the client site – disabled JetPack and voila – your plugin works. YAY!!!

    Please keep up with development on this, it is a MUCH needed addition to WordPress!! Thank you!!!!

    Plugin Author Marco Chiesi

    @marcochiesi

    Hi the_webscaper, this time it’s me not seeing your replies, which indeed I received in my mailbox. I suppose that forum messages are not published in real time.
    Anyway, I am glad you succedeed in running the plugin after all.
    By the way, thanks to your report I was able to find a workaround to let my plugin running in presence of the Jetpack’s “After the Deadline” plugin, which makes a little mess in the widgets admin page (it adds some configurations for its tinymce additions, but it doesn’t load the corresponding js files, so that it generates a javascript error preventing the editor from loading correctly). I’ll try to report this to Jetpack’s authors.
    The fix is avaialble in version 0.6.4.

    Plugin Author Francesco Canovi

    @thedarkmist

    the_webscaper: don’t forget to rate the plugin, if you liked it
    Thank you!
    😉
    Kind regards,
    Francesco-

    the_webscaper

    @the_webscaper

    Hi Marco!

    I’m so glad that I was able to help identify the bug between your plugin and Jetpack. And very glad that I was able to get your plugin working on my site.

    BUT… now I have another issue, I’m hoping you can help with a fix for. When I add HTML to the text widget using your plugin (on the HTML tab), it’s stripping out my
    and <p> tags. The content that I’m putting on the sidebars of this site are paragraphs and lists of contacts, so the ability to have line breaks (at the very least) is essential.

    Any suggestions? Thanks SO much!

    the_webscaper

    @the_webscaper

    Francesco – I will HAPPILY rate the plugin, and if we can get the paragraph/line break issue resolved, I will be adding this plugin to every client site I manage as well as installing it by default on all my new client sites. It’s really an invaluable tool, I don’t know why it’s not built in by default.

    Many thanks!

    the_webscaper

    @the_webscaper

    OH! My apologies – I didn’t see that you already had a fix for this. I have upgraded, and everything is working wonderfully. I’ve five-star rated this plugin, it’s awesome and I really appreciate your responsiveness.

    Thank you!!!

    Looks great, Marco and Fransesco.

    One thing that you might want to take a look at is the preloading of the dialogs. WordPress versions below 3.2 don’t have the wp_preload_dialogs function. You can just use the wp_tiny_mce_preload_dialogs function instead.

    add_action('admin_footer', 'wp_tiny_mce_preload_dialogs');

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Resolved] [Plugin: Black Studio TinyMCE Widget] New TinyMCE Widget plugin’ is closed to new replies.
Skip to toolbar