WordPress.org

Support

Support » Plugins and Hacks » Bit.ly Shortlinks » [Resolved] [Plugin: Bit.ly Shortlinks] Error in header

[Resolved] [Plugin: Bit.ly Shortlinks] Error in header

  • I don’t know if the plugin supports 3.1 yet, I’m sure there’s still some testing to do. I get the following error on my single post page when I activate the plugin:

    Warning]: Header may not contain more than a single header, new line detected. in /home/user/public_html/website/wordpress/wp-includes/link-template.php on line 2435

    Thanks for any insight you can provide. I’ll deactivate it for now.

    Dalton

    http://wordpress.org/extend/plugins/bitly-shortlinks/

Viewing 15 replies - 1 through 15 (of 24 total)
  • I do get the same error. Using the latest stable version of WP and this Plugin.

    Warning: Header may not contain more than a single header, new line detected. in /wp-includes/link-template.php on line 2239

    We get the same error.

    Warning: Header may not contain more than a single header, new line detected. in html/wp-includes/link-template.php on line 2239

    Add one more to the list – I encountered the same exact issue.

    I’m still on WP3.0.4.
    I have this problem as well. It does not appear on posts page.
    Unfortunately I am not able to pinpoint the problem as well.

    Same here.

    Using WordPress 3.1 RC + Hybrid Core + Prototype

    My error:

    Warning: Header may not contain more than a single header, new line detected. in /home7/webtwosp/public_html/mundowp/wp-includes/link-template.php on line 2435

    And YES, one more… ‘Sup with this?

    Add one more the list …

    I’m using 3.0.4 and I have the same proble with plugin

    Warning: Header may not contain more than a single header, new line detected. in html/wp-includes/link-template.php on line 2239

    Suggestions? Thanks!

    Me too! I use WP 3.0.4.

    Same here. I can’t believe there is no response yet when this many people are having the same problems. Is anyone listening? HELP PLEASE!

    Plugin Author Joost de Valk

    @joostdevalk

    If some could try to change line 13 to:

    $short = trim( get_post_meta($id, '_yoast_bitlylink', true) );

    ( adding in the trim() )

    if that fixes it I’ll push out a fix to wp.org

    @joostdevalk – Sorry to bug you more about this, just trying to get it working. I tried changing line 13 to: what you provided above.

    Same Error:
    Warning: Header may not contain more than a single header, new line detected. in html/wp-includes/link-template.php on line 2239

    When you get some time to look into this, I can help to troubleshoot this error.

    Plugin Author Joost de Valk

    @joostdevalk

    Hmm ok, the weird thing is I’m not getting the error myself so I’m having a hard time replicating and/or fixing it. Anyone want to give me access to their site so I can see the problem “live”? If so, please email me through my site’s contact form:

    Contact

    Cheers

    Plug-in seems to work fine except for one thing:

    In the new admin header introduced with WP 3.1, whenever I try to click the first option from the “Bit.ly” navigation item, the javascript prompt does not appear, and the page reloads instead. Any idea why this might be happening? Any help is appreciated.

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘[Resolved] [Plugin: Bit.ly Shortlinks] Error in header’ is closed to new replies.
Skip to toolbar