WordPress.org

Forums

[resolved] [Plugin: Better WP Secutiry] Warning + Fatal error (4 posts)

  1. ADBL
    Member
    Posted 2 years ago #

    Hi there --

    I'm getting these two errors after tweaking BWPS:

    Warning: require(/bla/www/wp-includes/pomo/mo.php) [function.require]: failed to open stream: No such file or directory in /bla/www/wp-settings.php on line 73

    Fatal error: require() [function.require]: Failed opening required '/bla/www/wp-includes/pomo/mo.php' (include_path='.:/usr/local/lib/php') in /bla/www/wp-settings.php on line 73

    In wp-settings.php, line 67-73 read:

    // Load early WordPress files.
    require( ABSPATH . WPINC . '/compat.php' );
    require( ABSPATH . WPINC . '/functions.php' );
    require( ABSPATH . WPINC . '/class-wp.php' );
    require( ABSPATH . WPINC . '/class-wp-error.php' );
    require( ABSPATH . WPINC . '/plugin.php' );
    require( ABSPATH . WPINC . '/pomo/mo.php' );

    I tried commenting out the last line, and then get:

    Fatal error: Class 'NOOP_Translations' not found in /bla/www/wp-includes/l10n.php on line 499

    In l10n.php, line 496-499 read:

    function &get_translations_for_domain( $domain ) {
    	global $l10n;
    	if ( !isset( $l10n[$domain] ) ) {
    		$l10n[$domain] = new NOOP_Translations;
    	}
    	return $l10n[$domain];
    }

    I believe I initially got these msgs after checking all options relevant to meta tags.

    The whole site is down (front + back). Thanks!

  2. ADBL
    Member
    Posted 2 years ago #

    I tried renaming/disabling .htaccess, still no luck.

    Please let me know what other info I need to provide if any (from php_info or else). TIA.

  3. ADBL
    Member
    Posted 2 years ago #

    I just realized that all subdirectories inside /wp-includes /wp-content and wp-admin had been deleted...

  4. ADBL
    Member
    Posted 2 years ago #

    Clean install done. I'll never know.

Topic Closed

This topic has been closed to new replies.

About this Topic