WordPress.org

Forums

iThemes Security (formerly Better WP Security)
[Plugin: Better WP Security] Problems Related to disabling it and user registration (9 posts)

  1. kyferez
    Member
    Posted 2 years ago #

    Bug 1) If I disable this plugin I loose the ability to login to my site and administrate it. I have to remove all the entries in .htaccess manually in order to restore access.

    Bug 2) If I enable the plugin after manually having deleted the .htaccess entries, it still thinks the settings are in effect.

    Bug 3) Possibly an incompatibility with another add-on. With this plugin enabled, new users cannot register.

    Note: I have the Hide-Backend setting enabled. I also have Login Security Solution and SI CAPTCHA Anti Spam installed.

    Appreciate your help!

    http://wordpress.org/extend/plugins/better-wp-security/

  2. While I'm not familiar with Login Security Solution and SI CAPTCHA, I can tell you that it is designed to restore settings if you re-activate however completely uninstalling the plugin will delete all the settings, database tables, etc. In addition, registration in most cases works fine. Are you using another registration plugin? Finally, What error message are you getting after disabling your site?

  3. kyferez
    Member
    Posted 2 years ago #

    Ok, understood about re-activation. It does seem to do that Ok.

    The error is not when I disable my site, but when I deactivate your plugin.

    When I deactivate the plugin and try to use the admin login slug defined with the Hide-Backend option, I get a 404 error. If I try to access wp-admin, I get a login page but cannot access the admin pages; I get forwarded to a 404 page. This seems due to the .htaccess rewrite rules still being in effect for the login slug.

    No other direct registration plugin, however the SI CAPTCHA does add a CAPTCHA to the registration page when the option is selected (which I am using). When the user attempts to register, WP does nothing but simply flashes them back to the registration page; no registration takes place.

    Login Security Solution prevents brute force access by forcing a password change for users who enter the wrong password too many times, forces inactivity timeout, and enforces password strength rules.

  4. kyferez
    Member
    Posted 2 years ago #

    Tried it again. Once this login bug starts, I cannot stop it without uninstalling Better WP Security. The problem is Not related to Login Security Solution; the problem occurred this time with that plugin disabled.

    The login problem is definitely related to the Hide-Backend setting being enabled. When not enabled, the login problem after deactivation of Better WP Security does not present.

    Finally, the registration bug is definitely related to the Hide-Backend also. When I disable that option, users can register with your plugin enabled.

  5. Thanks @kyferez....

    ....when you deactivate the rules are removed by the plugin. Can you confirm this is happening for you (I've just tested it on a couple of sites and it does seem to be working). Also, as I would like to get to the bottom of this for you can you please email me the contents of your .htaccess (sanitized of course) offsite at info [at] bit51 [dot] com so that I may get a better idea of what you have going on?

  6. kyferez
    Member
    Posted 2 years ago #

    Yes, they are removing... It appears before the plugin somehow was not actually disabling because I saw it still running after I supposedly had clicked to disable it... So the problem may not be related to deactivating the plugin; Now after a fresh reinstall of the plugin I am having the problem when Hide-Backend is enabled. I'm going to try and disable, uninstall, and fresh install again.

    I emailed you the .htaccess.

  7. kyferez
    Member
    Posted 2 years ago #

    I just uninstalled the plugin and reinstalled. Enabled nothing except hide-backend. Still problem occurred. Disabled all other plugins. Still problem occurred. Upon login, I get redirected to 404 page.

  8. can you email me at info [at] bit51 [dot] com so that we might be able to sort this out?

  9. bmnedirect
    Member
    Posted 2 years ago #

    I am having a similar issue. When the backend is hidden you can not register as a user or if you are already registered you can not login as a user. This problem has occurred over two different login plugins. I can still login as the admin by going through /admin. How do I fix this issue because I would really like the back end to be hidden.

    http://www.bmnedirect.com

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.