[Plugin: Better WP Security] (3 posts)

  1. Peter
    Posted 3 years ago #

    After the installation of Better WP Security on the main domain, I cannot access the pages of a subdomain any more. It generates a 404 error.

    Main domain:


    Page of Subdomain:
    http://snbchf.com/test/about --> 404 error


  2. Peter
    Posted 3 years ago #

    Second bug:

    A similar behavior for the admin area of the subdomain.

    I could access the admin area of the subdomain only after I removed the hide backend functionality in the main domain.

    How for the first bug it does not help, even enable directory browsing does not help.

  3. Peter
    Posted 3 years ago #

    I suppose it is the following problem:
    You must do things in the following order:
    1. Enable permalinks (write access to .htaccess required)

    If your .htaccess file were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all.

    2. Hide backend (permalinks required)
    3. Remove write access to core files (.htaccess et. al.) if really wanted

    Due the fact that Better WP Security is not able to reset the write access from disabled to enabled, this order is required

Topic Closed

This topic has been closed to new replies.

About this Topic