Support » Plugin: iThemes Security (formerly Better WP Security) » [Plugin: Better WP Security] Enable SSL on Login & Admin Not Working

  • I’ve been using Better WP Security on many of my websites and am loving it, it is such an awesome plugin.

    I am using a feature for the first time though and I can’t seem to get it to work. I have an SSL cert installed on my server, ready to go. I turn on SSL in Better WP Security – Options to do SSL by Content Page, and also on Admin and Login. I manually edited the .htaccess and wp-config as indicated in my dashboard.

    But…. it is still not using SSL for Login & Admin, and also when I check the dashboard it doesn’t seem to think I have it set up either because is still gives me this message in blue:

    “You are not requiring a secure connection for logins or for the admin area. Click here to fix.”

    When I click “click here to fix” it shows that all settings are saved and should be active.

Viewing 2 replies - 1 through 2 (of 2 total)
  • More Info – I changed WP Security to be allowed to edit my wp-config and .htaccess and the admin and login areas are working now with SSL, so I guess I was just manually editing incorrectly.

    So Admin and Login have the https & the padlock in the address bar – great!

    But – I turn SSL on for an individual page and that page is now https, but does not show the padlock in the address bar. This is the most important part because then my clients fill secure entering their data when they see the padlock.

    Why does the padlock show on admin/login, but not when I secure an individual page?

    K, don’t even worry about this post anymore :o) I’ve figured it all out – the padlock part is nothing to do with Better WP Security – I just had to make all the items on my page secure to get the padlock.

    Everything is working perfectly now.

    Thanks again for the great plugin!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: Better WP Security] Enable SSL on Login & Admin Not Working’ is closed to new replies.