WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Better WP Security] Better WP Blocking GoogleBot!

[Plugin: Better WP Security] Better WP Blocking GoogleBot!

  • ElleJG
    Member

    @ellejg

    Using 3.4.3

    I see someone else here saying they are having problems with Analytics. I tried to do a Fetch as Google in Webmaster Tools on a new site, and got an error message. Returning a HTTP/1.1.418. All pages that had been indexed are now deindexed. Not good!!

    Contacted my host and they said it was this plugin. Of course I had deactivated all plugins EXCEPT this one while trying to find the problem. They suggested trying to whitelist Google bot but I see no way of doing that. Deactivated the plugin, tried fetch as google and it worked.

    The weird thing is I use this plugin on multiple sites. I’ve only checked one other – I’ll be checking them all! – and Google is able to access that site. For the most part, I install all the same plugins on each site I set up.

    So a few things. WHY is this blocking Google and is there a way to whitelist Google if there is a problem?

    Oh, and one more thing. It appears that once you’ve enabled the banned default blacklist and added it, there is no way to disable this feature. That was the first thing I tried – before deactivating the plugin entirely – and once you disable the feature and save, it just shows as enabled again. I’ve tried this on my test site as well, and the same thing. No way to disable feature once enable.

    Thanks.

    http://wordpress.org/extend/plugins/better-wp-security/

Viewing 15 replies - 1 through 15 (of 35 total)
  • fulanoinc
    Participant

    @fulanoinc

    My site has flatlined after installing BWPS. Any word on what the problem is? Please help a guy out.

    ElleJG
    Member

    @ellejg

    Did your site get deindexed? That’s what happened to me. So you are the 3rd here to say you’ve had this plugin block GoogleBot in some way.

    And no, I have had no sort of answer, or even a request for further info to help diagnose the problem. I just deactivated BWPS and then Google was able to index my site again. Thankfully it was a new site and I was paying attention so not too much damage was done.

    The Hack Repair Guy
    Participant

    @tvcnet

    I’m fairly sure the bad bots block list includes no IP’s relating to Google so I can’t imagine that aspect of Better WP Security is at fault.

    I’ve been using that block list for well over two years with some minor tweaks and not had a single report of googlebot related issues.

    I got an emails from google webmaster tools saying “Google detected a significant increase in the number of URLs we were blocked from crawling due to authorization permission errors.”

    The errors that have arrised was after i installed this plugin..

    BWPS blocks GoogleBot for sure..

    Any idea what to do next after deactivating BWPS ?

    Exact same problem I had with WPBS. Blocked googlebots and destroyed my keyword rankings, traffic now 1/4 of what it used to be. Also multiple readers alerted me that they were being automatically logged in to one of my admin accounts after I installed this. Looks like a very useful plugin but unfortunately has a dangerous downside and should be avoided.

    I disagree. I’ve installed on hundreds of sites and none have reported any Googlebot blocking.

    I’ve seen just the opposite results (faster website, no effects on Google indexing, etc.).

    I think there is a lot more going on in this story.

    Before folks start pointing fingers let’s use a little common sense and process to troubleshoot.

    First, there is a recommended ban list in Better WP Security.
    Please attempt to reinstall the plugin, then see:
    Ban -> un-check the box next to “Enable Default Banned List”

    Then re-run your Googlebot check once again with it off.

    (I’ve seen an number of apparently competitor posted anti-BWPS posts recently, hopefully this not another one)

    I installed WPBS today on my new site and it blockacs google bot for me, do you guys find any solution for that?

    EDIT: i disabled WPBS and google bot works again.

    rbergeron81
    Member

    @rbergeron81

    I believe this is a problem with the “filter request methods” option under the tweaks tab.

    Turn it off, and Google bots will work again.

    Why does the “filter request methods” prevent Google bots from working?

    Handoko
    Participant

    @handoko-zhang

    Not very sure, but these are what I know, hope it helps:

    – This plugin may block GoogleBot, it’s true. I’ve ever seen GoogleBot and BingBot in my 404 error log.

    – Why? Due to not properly wrote theme and plugin I used, the bots were trying to looking for files (usually image) that do not exist in my website. So they generated 404 errors.

    – So, how to solve this issue? I put the a list of useful bots’ IP in my 404 White List.

    – How to do it? Click the menu > Intrution Detection > 404 White List, then put the IPs there.

    – What are the IPs? Here are the IPs that ever listed in my 404 error log:
    157.55.32.107 (BingBot)
    157.55.33.44 (BingBot)
    157.55.34.183 (BingBot)
    65.55.52.95 (BingBot)
    65.55.213.192 (BingBot)
    66.249.73.144 (GoogleBot)
    66.249.76.1 (GoogleBot)
    66.249.76.5 (GoogleBot)
    66.249.76.5 (GoogleBot)

    – Should we enable Default Banned List or not? The Default Banned List can banned many bad bots, but also some might useful bots, so I do not enable it.

    – So far, I do not have any problem with Filter Request Methods enabled.

    404 error means page does not exist.

    Handoko
    Participant

    @handoko-zhang

    If you enable Blacklist Repeat Offender on Intrusion Detection (404 Detection), it will automatically ban IPs that generate 404 errors after reach certain threshold. I did see Google’s IPs in my list of the 404 log. It means if GoogleBot keep generating some more 404 errors, it will be banned.

    Hi,

    Maybe BWPS conflicts with some plugin.
    It conflicts with w3 total cache, you have to install total cache before bwps. If i install after there’s no way to get total cache working.

    jdaviescoates
    Participant

    @jdaviescoates

    Oh, and one more thing. It appears that once you’ve enabled the banned default blacklist and added it, there is no way to disable this feature. That was the first thing I tried – before deactivating the plugin entirely – and once you disable the feature and save, it just shows as enabled again. I’ve tried this on my test site as well, and the same thing. No way to disable feature once enable.

    I’ve noticed that too, on a completely clean install of wp and an up to date clean install of BWPS.

    Also, if you go and manually change .htaccess to revert the changes, BWPS dashboard doesn’t pick that up and still thinks it is enabled (i.e. the line is still shown as green with no link next to it).

    The only way I could get it to reset was to delete and reinstall BWPS

    Handoko
    Participant

    @handoko-zhang

    Oh, and one more thing. It appears that once you’ve enabled the banned default blacklist and added it, there is no way to disable this feature.

    Never knew about it. Anyone please start a new thread reporting this issue.

Viewing 15 replies - 1 through 15 (of 35 total)
  • The topic ‘[Plugin: Better WP Security] Better WP Blocking GoogleBot!’ is closed to new replies.