Support » Plugin: iThemes Security (formerly Better WP Security) » [Plugin: Better WP Security] Ban hosts won't save if using IP range w/ hypen?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Currently it should only accept wildcards. This translates much easier in most server situations. Did I miss a spot that still says otherwise?

    Adding my question to this thread, I too am trying to move from using a hyphen to a wildcard but I’m having trouble getting this accepted. Would you please give an example of using wildcards for an example IP range, say, Russian Federation IP range 2.60.0.0-2.63.255.255.

    @maximan
    2.60.*.*
    2.61.*.*
    2.62.*.*
    2.63.*.*

    While I realize it is longer the performance improvement available with using only wildcards means I will not be changing it anytime soon.

    Couple of questions:

    1. Do you have a link to where I can download a complete list with wildcards to copy/paste into ban users. I could probably create a list but it would be much easier if there was a readymade source.

    2. Regarding performance, can you clarify what performance benefit there is using wildcards versus using CIDR format directly inserted in the .htaccess file.

    @maximan

    No ready made lists other than HackRepair.coms list.

    As for the performance problem, I had more than one instance of folks reporting problems where WordPress was hitting mem errors while processing long lists of hyphenated ips.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Better WP Security] Ban hosts won't save if using IP range w/ hypen?’ is closed to new replies.